Highlighting all connected pins

Sorry for this rather embarrassing question, but I cannot work without a solution for it:

I want to highlight all pins connected to the pin I just selected. Hotkey `doesn’t work.

It has been working in the default setup for decades, but s.th. has changes and I can’t find the correct config parameters.

Thanks in advance.


Welcome :smiley:
Could you please provide a bit more information as this is very vague, in fact I have no idea what the problem is. Please tell us the version number of Kicad you are using by going to the ‘Help’ button and copying your details there and also the OS of your PC and much more detailed information about the the problem, ideally a photo or a file of the troublesome project.

Your post contains a little bit mixed up informations:

  • you write in section “Layout”
  • but you talk about pins - which are only available in the schematic editor as part of symbols

So after you answered mouseys question you should clarify:

  • highlighting nets+pins in schematic editor?
  • highlighting tracks+pads in pcb editor?

Are your hotkeys assigned properly?
does the backtick (`) key work at all?

You can search for hotkeys related to highlighting in the Preferences:

Also note there are (at least) two different net highliting tools in KiCad and they work slightly differently.

Assuming I don’t have the schematic editor open. I can change that, but I’m happy with jsut finishing the board in the layout editor.

Since ages I used to click on a component pin, which gets highlighted, and which is for instance connected to net42, and all other pins of any component connected to net42 get highlighted as well. It is an essential help for placement and routing.

I’ve been using KiCad since - I guess 2005 - and can’t remember I changed preferences.

So I have this problem now since a quick board in Kicad 7.0 and now want to restart a larger one in KicaD 8.0. But without that feature, I’m pretty lost.

After reading doc and forum, I tried hotkey ` like crazy, but it didn’t work.

I know is is embarassing and thanks for your reply in advance.

Cheers, pin

1 Like

Right-Click the Net and select Highlight (in V7 but, I imagine it still works in v8)

Thanks BlackCoffee, but what if there is no routed net yet - let’s assume I’m still in the placement phase - and I’m “forced” to just select a pin.

  • try to assign a different hotkey. On some systems the backtick character does not work
  • explore the global preferences. Look especially at Preferences–>pcb editor–>editing options–>left click mouse commands (set CTRL==highlight net action)
  • be sure to have “Pads” and “tracks” enabled in the selection in the bottom right corner

Thanks mf_ibfeew, Pads and tracks are enabled, and after spending a few hours yesterday I’m sure I will not find the right preferences \ hotkey combination.

It’s standard windows 10. So I’m not sure if it is related to the system.

I assume the question is, can s.o. confirm, that the behavior I try to explain is still implemented in V7\8.

Thanks for your help.

as confirmation: highlighting works for me:

  • CTRL+left click (after enabling in the global preferences)
  • hotkey also, but not the backtick (as mentioned, on some systems this character doesn’t works. Depends on windows language/keyboard settings).

For me it works too in v8 just like it always used to. Including cross probing between schematic and PCB.

And again: Check whether the settings for the hotkeys are still assigned properly, (even if you have not changed them yourself).

In below image #1, I cursor-hovered (not selected) the Pin/Pad and selected my Assigned Hot-Key (Shift-H). This Pin/Pad is assigned to a Net (COFFEE)

In below image #2, I cursor-hovered (not selected) the Pin/Pad and selected my Assigned Hot-Key (Shift-H). This Pin/Pad is Not assigned to a Net (thus, the Default Net (= No Net)

Thus, you can see only the Un-Netted Pad/Pins and Trace at lower right (and, F-Cu single-line-trace) get highlighted.



Thanks team, I was able to make it working, with the right preferences and an adapted handling.

This tool and forum is awesome.

Thanks again.

Cheers !


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.