Hidden pin names, how to make them visible?

The pin names for one of my parts isn’t showing up in the Symbol Editor (nor Eeschema). The pin number does show up.
Double-clicking on the pin to reveal ‘Pin Properties’, I have ‘Visible’ checked. The name and number text size are 59mils. In ‘Symbol Editor | Preferences | Preferences…’, the default pin name size is 50 mils.
I can’t find any significant difference between symbols showing pin names and this one symbol that does not display its pin names.
How can I force the pin name to be displayed on the symbol in the Symbol Editor (and eventually Eeschma)? I am using KiCad version 5.1.9.

Can you take a screenshot like this? You’ve been ‘leveled up’ in case you need to post more.

Have you checked this settings:

Thank you both, and thank you Piotr,
That was it.
Instead of clicking on the pin to edit the properties, I need to go to the Symbol Editor menu | Edit | Properties.
Thank you!