Help creating De Morgan representation

I’m trying to create a De Morgan representation for the 74LS74. I go into the symbol editor, call up the 74LS74, click on “Edit symbol properties”, check the “Has alternate symbol (DeMorgan)” box, click OK, answer YES to the question, but then what? The “Show as DeMorgan…” buttons at the top are still disabled and if I again click on “Edit symbol properties” the “Has alternate symbol (DeMorgan)” box is now unchecked. But if I call up 74LS00, which already has a De Morgan representation, the “Show as DeMorgan” buttons are enabled and you can switch back and forth between the AND and OR representations.

Any ideas what I’m doing wrong? There is mention of De Morgan in the manual, but it is pretty opaque and doesn’t actually explain HOW to get the other representation.

Thanks

Works for me. I brought up the 74LS74, checked the DeMorgan box, then the two representation buttons were enabled in the toolbar and when I switched to the alternate representation I was presented with a diagram missing the square but with pins and properties which I would have to edit for inverse logic. I didn’t proceed further and it would have to be saved to my library, of course, as the system library is read-only.

What version are you running?

Application: Eeschema
Version: 5.1.5+dfsg1-2build2, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-135-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OpenCASCADE Technology: 7.3.0
Curl: 7.68.0
Compiler: GCC 9.3.0 with C++ ABI 1013
Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=OFF
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Well I’m using v6, so there you are. And v7 is just around the corner.

V5 is what came with Ubuntu 20.04. Perhaps a good reason to upgrade. Thanks for the info.,

Works for me also.
Running 7.0.0-rc (Kicad nightly)

The official repos of many distributions are out of date because they took what was the stable release of the application at the time the distro was released, and didn’t upgrade for fear of cascading dependency upgrades, and because KiCad is advancing quickly. So to stay up to date use the KiCad PPA.