Having trouble with library install


I just installed a fresh copy of Kicad on a fresh copy of Linux Mint. I’m scared that I won’t be able to navigate to my libraries because, well, I couldn’t the last time I tried a fresh install.

I ran these commands from the shell:

sudo add-apt-repository --yes ppa:js-reynaud/kicad-5.1
sudo apt update
sudo apt install --install-suggests kicad

I noticed that the libraries were not present on my OS so I git cloned /KiCad/kicad-footprints.git and /KiCad/kicad-symbols.git

Now I’ve started up KiCad and I’m staring at a pop up window titled Configure Global Symbol Library Table. The “Copy default global symbol library table” radio button is greyed out. Should I select “Copy custom global symbol library table?” I selected the sym-lib-table file from my git downloads.

Is this all there is to it?

I had to configure the path for KICAD_SYMBOL_DIR to the library for it to work properly. Thankfully, I’m not getting any errors now in Eschema. Unfortunately, I still can’t get KiCad to locate the footprints library. In the Configure Paths pop-up, I added KICAD_FOOTPRINTS_DIR and pointed it to my library path because it wasn’t there at all.

I’ve tried deleting the .config footprints file and it walks me through there part where I locate the fp-lib-table file on start up, but it still doesn’t work. I get a pop up screen saying “Errors were encountered loading footprints” and then it flags a whole bunch of footprint files that are in some strange location. It doesn’t even acknowledge the fact that I just located the fp-lib-table in the correct directory for it!

I figured it out!! Somebody named the kicad-footprints library variable KISYSMOD instead of KICAD_FOOTPRINTS_DIR

This link really helped me out:

1 Like

That’s how it’s ‘always’ been :wink:

KICAD_SYMBOL_DIR is new and better human readable and has been introduced with KiCAD 5.0.x to get EEschema library configuration up to the same level that PCBnew (layout) had since version 4.x
At some point KiSYSMOD will probably change into the variable you guessed.

If you want to see how they are being used, click on Preferences and Manage XY Libraries…


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.