Having relay library problems, foot print exists but get following error

This is my first time doing PCB side, really stuck on this one. Try to get Finders *.31 relay to work. Tried all the others get same error in the THT relay lib.
Please advise.

How did you assign the footprint to the symbol?

Did you run CvPCB from the top menu bar in Eeschema?

This library used to be called Relays_ThroughHole.pretty

thanks for your help, I did the following in schema, Annotated, ERC, netlist, then assign foot print. All the parts in the foot print tool, have correct match and verified each pad set with list. Saved it.

then next step is opening pcb tool, after setting up layout size and saving blank board, I hit netlist button. During the Read Netlist (from one just generated) we get the error message about Relay_THT.

Did I miss something, I am using existing prebuild libraries from KiCad.

First thing to try is to close and restart KiCad.

If you can “see” the footprint, maybe KiCad hasn’t yet been told it see it.

Wrong order: assign footprints first, then generate the netlist. Open PCBnew, import netlist.

Tip: PCBnew stacks all components in a large single pile somewhere on the sheet. Select the manual placement icon from the top tool-bar, then right-click in the sheet for a menu. Click “Global Spread and place” -> “Unlock all footprints”, right-click again for the same menu item, then click “Spread all footprints”.

Before importing the netlist, first create the outer boundaries of the PCB: select as working layer (drop-down menu in the top tool-bar) the Edge.Cut layer, this is the actual PCB layer. Roughly draw the outlines of the board, then use the edit option for each line/curve/object to precisely position it on the X/Y axis. You’d need some spacial awareness and math skills for it though :wink: By default components are on the top layer, flip them to the bottom of the PCB (i.e. the underside) with the F key.


Thanks Dutch master, was a sequence problem, I need to assign before building netlist. Knew it had to be something simple. :slight_smile:

The “Wrong order” does not create the issue presented by the OP.

If the “wrong order” was the problem, the error in PcbNew would be "No footprint defined for component “xyz”. It would NOT be, "IO-ERROR:fp-lib-table files contain no lib with nickname "Relays_THT’ ".

Only if the field “footprint” was empty. If the field was filled with “Relays_THT:xyz” instead of “Relays_ThroughHole:xyz” it was a wrong order issue for sure.