Have 1 mil imported schematic--how to easily adjust parts/wires?

I imported an Eagle Schematic to Nightly Build. It was on 1 mil (inches)

The Lowest setting I can get on KiCad is 5 “px.” In the schematic editor when I zoom in, I see that the wires are connected and the pins and wires are “between” the 5 px settings, which seems to imply that a px (pixel) is one mil. (Note: dots disappear (too gray) on zoom, but lines stay.)

I have a lot of connecting wires to this part. Is there a way to easily “center” the part on at least the 5 px boundaries and the wires connected to its pins in preparation for moving it up to a KiCad’s required 50 mil setup? (without having to touch each and every wire!) I have noticed the wires don’t move like they do in Eagle. In it a click in move mode on an end moves only that end. In KiCad, it appears to move the entire length of the wire, unless I am doing something wrong (very likely).

I know, I am lazy.


Any chance you can share some screenshots of what you’re doing? I’m not aware of a setting in the schematic editor in px. I can set the grid to 1 mil directly.

It seems to me that recent KiCad builds are able to take symbols from off-grid onto the set grid when you move them. But you might need to open the symbols in symbol editor in order to place the individual pins onto the grid? “50 mils” is the standard and recommended grid setting for the schematic editor.

I use quotes because the distance does not relate to anything real as with footprints in the pcb editor. There are no actual important dimensions in a schematic diagram.

I had a problem today opening and old schematic (v5
.99 I believe) with the newest nighthly, some components and wires where not in the grid (wtf?) while I was trying to think how to go about it, I right clicked on a component by mistake an noticed an option called “align to grid’, I selected the whole schematic, right clicked, selected” align to grid"… Presto!! All done! Nicely aligned!

Thanks a bunch to whoever implemented such an useful feature!

So just to be clear…this whole schematic: Some of it was initially on grid and some of it was off? Then when you selected all of it and (context menu) selected “align to grid” that fixed it? Did it collide any components or make undesired connections?

This is from a nightly build of a few days ago, on mac osx catalina. The minimum is 5, and the text beside the dropdown is “px”

Thank You! I did the same thing and it appears to have worked!

It is aligned to the 5 px grid on the schematic. I don’t know if it is aligned to the 50 mil, as I have not yet discovered how to do that.

Oh, this is just for display - grid lines closer together than this will not be shown. It doesn’t affect the actual grid pitch, just how it’s rendered. Right click in the schematic and use the Grid menu to change the grid pitch.

I have an observation, not a complaint. There may be a small amount room for consolidation here:

On the MacOSX version, there are preferences under the Eeschema menu.
There are preferences under the “Schematic Setup” option under File Menu.
There are preferences under the “Edit Text and Graphics Properties” under the Edit Menu.
There are preferences under the Preferences menu.
There are preferences under “Grid Properties” under the View menu.

Indeed! Wouldn’t be a CAD package without a dozen different places to change settings :wink:

Thanks! That worked. Note: There are preferences under the right click menu also.

I set it to 50 mil and selected all and did “align elements to grid” and it seemed to work.

I’ll start another thread on my next problem.

Hmm. You are falling behind. There are only 6 places to change preferences. You need 6 more.

I actually would prefer 7 places. One which would be a searchable consolidation of all of the above (without dropping the previous 6 places.) It would make it more fun to locate hidden corners.


1 Like

I draw it originally on a v5.99 version, when I opened again yesterday with the newest nightly, some components and wires where off grid, it was not a complex schematic so there was no crossing or anything, it just worked ®

Is there any place to set the preference on how many places you get to set preferences?

I like your registered trademark! :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.