Grounding Exposed Die

HVQFN48 package with an exposed die pad that needs to be grounded. I can’t add a track from a pin to the die pad because there are also exposed wires in this package, so I need to use vias inside the pad.

Here is the schematic symbol - pin 49 is the exposed die.


Here is the footprint, designed by me.


The part is on the top layer and I have a ground pour on the bottom layer. When I do the ground pour and then add the stitching vias it is connected. However if I then undo and redo the ground pour KiCAD avoids connecting the vias.



It seems KiCAD is not associating pin 49 with GND.

If I click on pad 49 and go to edit the net name is “no net”. I change that to GND, undo pour and redo pour and now it looks good. Shouldn’t it be able to automatically associate the pad with GND based on the schematic? What mistake did I make?


What OS and KiCad version?
Your workflow is correct

Application: Pcbnew
Version: (5.1.6)-1, release build
wxWidgets 3.0.4
libcurl/7.66.0 OpenSSL/1.1.1d (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.1.1) nghttp2/1.39.2
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.71.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.66.0
Compiler: GCC 9.2.0 with C++ ABI 1013

Build settings:

Windows 10 64-bit.

You are running an old release, there have been four point releases since to 5.1.10, which have fixed many bugs.
Worth trying as there is nothing obviously wrong with your schematic

Have you tried the QFN-48-1EP_7x7mm_P0.5mm_EP5.3x5.3mm_ThermalVias footprint in the stock library?

if it meets the package dimensions then this is easier to use. Also, you could temporarily use the stock footprint to see if you still have a problem connecting to GND, this will point towards a possible issue with your custom footprint, zone setting issue or something else

1 Like

Thanks for the suggestions I will update and see if there is still a problem. Note that between pad 49 and the pins I have four rectangular keep out zones forming a ring around pad 49 (on front copper only).

I think you could get the same function by clicking on pad 49 in the layout and changing the clearance to the width of the keep out area. That should force copper away from 49.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.