Grid snap not being respected in KiCad 8

an annoying problem with KC8… traces and components don’t snap exactly to the chose grid, but instead snap to very very close to the grid. Never had this issue with v7. What setting fixes this?

screenshot shows that the component is close to (very very), but not exactly where I want it to be.

2024-02-29 16_33_57-Footprint Properties

What is your OS?
What is your grid setting?
Have you changed grid setting or units of measurement since placing the footprint?
From where did you get the footprint?

Are you moving the footprint by the pads, the silkscreen lines or the actual center of the footprint?
To make sure that it’s the center of the footprint, go to preferences → common and check “Warp mouse to origin of moved object”.