Grid & Pins Issues

I would appreciate if someone feed me back in this issue. It is impossible to connect wires to pins. In addition, there is no grid. I tried changing the general setting put nothing changes after couple of restarting as well. Thank you.

Is this from the official libraries or did the symbol come from somewhere else?
The first icon on the left below ‘file’ turns the grid on and off.


Right click on empty spot of schematic to set grid spacing.


In eeschema, you should ALWAY use the default grid as they libraries are based on that grid spacing.

If you changed the grid, delete your schematic and start over.

What have you tried to make wire connections?
There are lots of videos on YouTube.

It is from official library. Apparently, even though I downloaded the version 5.0.0 stable, it has issue like this one!

What is the default grid? 50.00 mils?

Yes. Mils is irrelevant. We like to think of them as ‘unit-less’ to avoid confusion.

Yes, after deleting the symbols and re draw them, solved the issue. Than you.

Actually, it is relevant.

No, it isn’t.
It is relevant the quantity 5, 10, 25, 50… but not the unit inch, km, mm, lightyear.
Maybe instead of unitless, unit agnostic should be said. Anyway the idea is the same.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.