Grid lines vs grid dots

Pardon my ignorance here but I’ve spent a fair amount of time trying to figure something out without success. Somehow in PI’ve changed the “grid dots” to “grid lines” and I can’t get it back. These extra lines all over the place are driving me crazy and the only way I have of getting rid of them is to hide them. This works but I miss my “grid dots”. I’ve looked under Preferences->General and Preferences->Display but I don’t see anything I can use to make the lines turn back into dots. I’ve also done a fair amount of google searches without success. Any help will be greatly appreciated. Thanks.

Look under dimensions->grid :wink:

Okay, I forgot to mention that I also looked there but didn’t see anything I could use to change the lines back to dots. Maybe I am just really dense?

Okay. Does this not exist in kicad stable?
Well i have a selector at the right where i can select between dot and line.
(But i’m using kicad nightly builds.)

Hm i really don’t know where this setting is stored. (I checked a few options with a diff tool.)
It is not saved in any files in [~/.config/kicad].
It is not saved in /usr/share/kicad/templates/
It is not saved in the project files.

Currently i’m out of ideas. Maybe i look into this later on.

In the stable release 4.0.x, I think legacy canvas has dots and opengl has lines. The option to change is not yet released.


For those using KiCad 5, go to Preferences --> Display Options… --> and choose a “Grid style”, such as Dots, Lines, or Small crosses.

Version: 5.0.0-rc2-dev-unknown-f73b9a5~65~ubuntu14.04.1, release build

I just wanted to let you know how to get rid of the lines in KiCad V4 as I had the same problem and it drove me crazy.
Turns out I had accidentally pressed the shortcut for OpenGL mode.
You just have to click on View -> Switch Canvas to Default or press F9 to switch back to the default graphics engine.


These extra lines all over the place are driving me crazy and the only way I have of getting rid of them is to hide them.

Just for your info. The default for lines instead of grid is really ugly. I don’t remember the default grid color, but here is how it looks with (128, 128, 128).
Indeed, you have lines everywhere and sometimes lines are as thick as traces.

The setting I use for the grid color is (48, 48, 48). In this case, the result is as follows, around the same area.

The good thing compared to dots is that whatever the scale, you can see it. And if you tune the grid color good enough, it doesn’t harm the PCB view. For grid color, go to the layer manager on the right, choose the item pane and double click the square facing the grid checkbox.

Beside this, another advantage of lines is that you can see both grid and subgrid. In the default grid color, of course, it’s a bit too visible.

In gray(48, 48, 48), it looks like this, and you get both grid and subgrid in different thickneses.


1 Like

When I was choosing my preferred grid, I didn’t think of changing the grid color and the lines were just too much. I chose dots (also has the emphasis on the 10s) and like them. Maybe one of these days I’ll give the lines with a modified color a try, but I’m happy with the dots for now.

I guess that is why we have options. :sunglasses:

1 Like

This is an excellent set of grid display settings. Thanks!

Just for your info: the same adjustment is now possible in 5.1. I just downloaded it to have a test run.
The original setting was quite dark. I have set the grid gray to (240,240, 240) and the result is as follows:


It would be better with non-tansparent labels but at least it works.