Graphics crash while saving symbols

Ok so silly me thought I could just create a schematic and board and 3d view using software rather then doing everything by manual means like I have done for 50+ years.

things worked out great until I was thrown a curve. I have an off board Battery pack array, off board switches, off board modules, and off board solar array. While I can just leave them as named connectors, a symbol showing a special purpose wound be more appropriate.

seams kicad 5.0 can’t create libraries … it just crashes. I can add existing but none are available with appropriate symbols.

I can create the symbols but… 1) can’t save it due to crashing upon save, 2) the symbol can have the power output (+) but can’t have the power ground (-) pins.

Final thoughts are why doesn’t any of the eeschema software have links to footprint & 3dview previews when you are trying to find the correct symbol. I make the statement because when I drapery software years ago (25 years to be exact) when you browsed for a part it showed the dimensions view and the 3dview so you always knew you selected the right one.

Sorry can’t seem to upload the graphics of my symbol, footprint, or 3d views.

Well, you do want some sort of connector for where the wires of the off-board parts are soldered to the board. This can either be an actual connector, simple holes in the board of the correct size for soldering the gauge wire you want, or a more detailed footprint with holes in the board for soldering the wires and 1-2 additional non plated holes to thread the wire through the board to act as stress reliefs. Unfortunately, KiCad is primarily targetted as a PCB design software, not a system design software.

But there is a trick to put off-board components on a schematic and not have them show on the PCB. If you put a hash-mark before the reference designator the part for that symbol will not be on either the PCB nor the BOM. I think the next version has more granular control without using the hidden feature of the hash-mark, but that version isn’t expected until later this year. (It is currently available as 5.99 and should be considered beta software.)

Version 5.0 is not the latest version with the most up-to-date bug fixes (known as the stable version). Currently (as of 2021-03-31) the stable version is 5.1.9. Crashing is unacceptable behavior and not seen on the majority of people using 5.1.9. What is the exact version you are using and on what platform? (The easy way to answer this question is to open the About window in KiCad and click on the button labeled Copy Version Info to put the full version information on your computer’s clipboard. Then paste into your reply here. It looks like a lot of unnecessary information, but there is some important information there that you may be asked about if you don’t provide the full version information.

The libraries that come with KiCad do have some parts like that. But many parts are jelly-bean parts and the KiCad librarians (who are all volunteers, BTW) can’t be expected to know all the parts that you have available to you. A simple example is, are you using Vishay or Yageo resistors? Are you using 1/8W resistors or 5W resistors? Are they SMT or THT? KiCad’s libraries have the symbols (schematic) separate from the footprints (PCB) just for this reason so you can have a many-to-many relationship.

You can set up your own libraries like that by explicitly declaring a specific footprint for each symbol that you use.

For a better understanding of how the libraries are used in KiCad, please refer to this FAQ item:

2 Likes

Blockquote

Application: KiCad
Version: 5.1.8-5.1.8, release build
Libraries:
wxWidgets 3.0.3
libcurl/7.66.0 OpenSSL/1.1.1d-fips zlib/1.2.11 libidn2/2.2.0 libpsl/0.20.1 (+libidn2/2.2.0) libssh/0.8.7/openssl/zlib nghttp2/1.40.0
Platform: Linux 5.3.18-lp152.66-default x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.3 (wchar_t,STL containers,compatible with 2.8) GTK+ 2.24
Boost: 1.66.0
OpenCASCADE Technology: 7.3.0
Curl: 7.66.0
Compiler: GCC 7.5.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=OFF
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Blockquote
My version is 5.1… but thought it was 5.0 because that is what the link to app says.
yes running on linux openSUSE 15.2 Leap

On my current schematic it complained about no power reference until I included a battery holder as even the power symbols said no power to global power reference…

Even for 5.1.9 after 5.1.8 some crashes have been fixed, for example this: https://gitlab.com/kicad/code/kicad/-/issues/5740.

If 5.1.9 crashes you should give more detailed explanation about the situation, exact steps so that anyone can follow them by just reading and repeating them “blindly”. A screencast often helps.

5.1.9 is available for openSUSE 15.2 Leap in the Electronics repo. You should upgrade.

well I tried to upgrade to version 5.9 and it appears it is for tumbleweed not 15.2 so need to see if I am not using kicad right…

Recently I added digikey & partner libraries which took several attempts. where kicad libraries are in /user/ folder as read only, I had to put digikey in a separate partition in my user space. Libraries are done global as I don’t want to have to reinvent library associations for each project.

I then tried to follow manual for create new symbol and found it didn’t really sat gow to do it, just how it is structured. Next I tried to follow create new library from main screen but the new library feature [first icon on left below menu was not the stated New Library but was create new project]. So went looking around and finally found Manage symbol and Manage footprint libraries under preferences.

under manage symbol libraries there are rwo read only library refernces with a blank list above. only option that seemed right was create new blank line and fill in info. So i gave it a name Pwr_symbols and went to specify where to build it. This of course failed as you need to set an existing folder with .lib files already in it. So only option is select cancel because there is no create folder or lib feature and upon click of cancel I get segmentation fault and the kicad program crashes.

So next I tried to copy a symbol for modification from a system read only file, using export and again it crashes. Then I tried editing a symbol by choosing a close symbol and making a copy of it. This seamed promising but I noted that while I can make one pin power (+) as output, there is no option for defining a ground pin so it is left passive. Obviously, I can’t save the library if it is read only so again I choose cancel and get the dreaded segmentation fault & crash.

I have the desired component look as a bitmap image but based on the short attempts working with libraries that failed I am thinking why waste my time if i can’t create or edit libraries.

Really what are my choices, but to go back to manual methods made from output of the working parts of kicad. I can print the designs 1:1 as image. hand modify the image file, then print to transparency (PMT) and convert to negative for processing. The option of making a gerber file and sending it out for production was my original goals. Gerber worked fine with on board battery in a past project. Didn’t work for a project using an AC adapter and now not working for use with Battery Pack, and Solar. Someone recently said kicad was targeted at PCB creation not systems. To me this makes no sense. Where a system employs PCB’s and other integral parts to make up the system, each PCB needs to be able to be powered (some internal some external) and communicate with outside influence which can be switches, sensors, other PCB’s.

A few short comings are delaying 4 major projects, Solar-Electric EV Tricycle, Solar-Electric EV Motorhome, Smart coach controller, and Solar-Wind house management controller. For those who are wondering what I am up to. 12 PCB;s at last count.

5.1.9 (not 5.9) is available for 15.2. I’m running 5.1.9.

Yep it was me. Should have read all responses first. My error was that I followed someone who said go to main screen where you select projects and choose first icon (new library) where reading the referenced links above identify you need to use create new symbol and from that screen you can choose create new library for the symbol or add/modify existing symbol from an existing library which is read/write rather than read only. And where I was specifying Power Point (global) it should be a 2 pin connector with defined Power output (+) and power input (gnd).

One part solved now what about the symbol from bit map? Aids in schematic view if you can se the electrical connector and it has a battery pack or solar or wind designate along side. button is there but haven’t found how to use it?

And before I forget, thanks to those who have responded.