GND Zone not connecting to GND PIN

Hello,

I have a strange problem that the GND pins of one component that I made are not connected to the copper Zone. See the Picture.
The GND Pin is a regular circular through hole pad. See also attached picture of the properties of that pad. What’s wrong here?

unconnected

Greetings,
Chris

Check the zone connection property in Local Clearance and Settings tab, for the footprint and for the pad.

Thanks! That did it. It was set to “None” somehow.

Greetings,
Chris