GND Pads not connecting to pour

Dear All,

I am currently facing a problem I can´t figure out how to solve.

In short terms: a GND pour on a seperate layer is not connecting to all GND THT pads of the board. The pads are part of a footprint and used as thermals.

On the same board another component with a similar setup connects without problems (see below). Since I can´t see any difference I made during the creation of the components I don´t know where to look next.
Any suggestions are appreciated!

Kicad is version 5.1.4 stable on Win10x64.

Thanks and best regards,

Looks like the individual pin ‘thermal relief’ setting might be set to none.

Or the footprint is set to none.

Also the setting is called “connection to copper zone” (one of its option is then “thermal relieve”, default is by parent).

The footprint settings are found in the footprint properties dialog (footprint editor while the footprint in question is open -> edit -> footprint properties or button in the top toolbar) under the local clearance and settings tab.

For pads the settings are found in the pad properties dialog (right click on pad -> properties or hotkey e) again in the local clearance and settings tab.

Note that your thermal spoke width on the left is wider than your pad spacing on the right. That means that the thermal relief from the adjacent pads will overlap the thermal spokes and the spokes themselves will be removed. You can set the pad connection to solid, change the thermal spoke width to a thinner spoke or space the pads wider.


Hey Guys,

thanks for helpful and quick responses!

The “Pad Connection” was set to “None” for these pads in the footprint settings.
After changing, it now connects without any problems to the zone.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.