GND net name not named GND

Hi, Is there a way to have equipotential nets named the same way ?
For exemple, GND is connected to M27 and Y59 here:

However, their net name are Net-(U1-PadBJ50) and Net-(U1-PadM3). Shoudln’t this be GND ?
When routing, it’s not obvious that those balls are GND:

Am I doing something wrong ?

Franck.

Edit the symbol to whatever makes sense to you?

Edit. Closer look all the others got assigned to GND? What is PadBJ5?

“GND” is a quite important thing in electronics, as it’s usually the reference used for any voltage. Voltages are never “absollute”, there are only voltage differences between different parts of the circuit, and sometimes you want different shades of “GND”.

The symbol you used, is not “GND” but “Earth” (Which may have the same potential, but has different meaning.

But anyway.
I assume you took that symbol from the “Power” library in KiCad. (Edit: Oops, probably wrong assumption. See below).
It’s name should still propagate through the netlist.

“Net-(U1-PadBJ50)” is a generic name, and KiCad only uses those if the the net has no label.

I just saw that your “Earth” symbol has 4 horizontal stripes, while KiCad’s only has 3 stripes. So I guess there is something wrong with your non-standard “Earth” symbol and it does not add a wire label to the net in the way KiCad’s own library symbols do.

You can change these symbols in one go with: Eeschema / Tools / Edit Symbol Library References and then:

  1. Search for your non-standard Earth symbol.
  2. Search for the symbol you want to replace it with.
  3. Click OK
  4. Trigger a redraw in Eeschema (For example with zoom) to update the graphics.

But… Both have the same net name: "Net-U1-PadBJ50"
Ah, You mentioned “Y59” for “Net-(U1-PadM3)” while your screenshot mentiones L27. Confusing indeed. Labels are quite useful for net names :slight_smile:

Anyway, changing the GND symbols as in my previous post should fix it. Alternatively, you can just add a label to your GND net. Power symbols act (very much like) global labels anyway.

I know this symbol is not meant to be used as an electrical reference. I’m using orcad for 10+ years and because it is the symbol used as GND, I now use it like this and I like it this way.

But anyway ::slight_smile:

My power symbol was indeed wrongly defined. Pin was not of type “power input” and then I didn’t know the pin name is used as the global label name for this symbol.

Thanks for the hint.

Franck.

Hey fjullien,
First of all, as seen in the screenshot below, you can just use the GND symbol from the schematic library. All the pins that are connected to this GND symbol will be shorted together and the net name will come as GND.


Secondly, if you want to change the name of a net from the default name that KiCad gives, then please follow the steps below.

  1. After connecting the required pins, click on the option net label as seen below.
    image
  2. Then click on the required net and a dialogue box shows up in which you can give the name you want for the net.
    image
  3. Once a name is given you can place the label anywhere on the net. (Make sure that a small square does not show up as it means that the label is not connected to the net)
  4. Click on generate netlist and then import the layout to Pcbnew.
    image
  5. You can see that the same name appears over there.
    image
    image