Globally Edit Reference Designator Text

Is there a way to globally edit the text size of all reference designators in PCBnew?

I’m working on my first KiCad project, and I’m at the point where I’m ready to clean up my silkscreen layers. Many of the reference designators are defined with a text size that is too small for my fab, and I’d like to know if there’s a convenient way to globally change all reference designators on the PCB to use, say, 50 mil text with 5 mil lines without editing each one separately.

Edited to add:
DOH! I just found Edit -> Reset Footprint Field Sizes in the PCBnew menu, which does exactly what I need.

1 Like

I need to do the same thing and found your post. I changed the setting under Edit->Set Footprint Field Sizes and I don’t see any effect on the already placed footprints. I tried zooming in and out to refresh the screen and Redraw (F3) and still no change. What am I missing?

It works just fine for me. Did you check the appropriate check box(es) in the left side of the pop-up window? Try checking all of them and then setting one or more of the sizes to an absurd value just to see if anything changes. If that doesn’t cause a visible change, then try changing the canvas type under the View menu, because in older KiCad revisions I’ve noticed screen drawing issues in some of them.

Thanks for the quick reply. Weird. I tried it again and now seems to work. Operator malfunction, perhaps. :slight_smile:

Dude! Soooo glad I found your post. I realize this is an old thread but that doesn’t change its relevance. Thought I was going to have to do this to each of my >100 components manually.

Searching semi-obvious terms in the Pcbnew manual doesn’t seem to uncover this handy little feature. Something that could be added perhaps?

Hello everyone,
It’s not working for me. I am using KiCad v 5.0.2 with Ubuntu 18.04.1 OS. I go to Edit>Set Footprint Field Sizes…>Set Text Size and check the Reference designator box. It has Current Text Dimensions of Width 1 mm, Height of 1 mm, and Thickness of 0.15 mm. I click on OK but nothing changes. I’ve tried Preferences>Modern Toolset (Accelerated)–F11 and Legacy Toolset–F9. Does it matter what is checked under Layers Manager for Layers or Items? The board is in Pcbnew (Standalone) mode, does that matter?
–Thanks, Larry

It works if the reference designators which you want to change are the primary ones, created in the footprint by “REF**” (in the standard library that’s in the silk layer). Secondary reference designators, created by “%R” (in the standard library in the fab layer) aren’t updated by this. You have to use “User defined” checkbox for them.

Just FYI, in the future 5.1 will have much more powerful dialog for changing these.

Which ref des is on which layer seems to be the other way around from your description. Under the Layers Manager in the Layers tab I can click on the F.SilkS and F.Fab choices to turn that layer on and off and I can tell which layer the ref des is on. When I check the F.SilkS layer and pick on the ref des, I go to the Properties… choice and get “Text: %R” and “Layer: F.SilkS”. Whereas when I check the F.Fab choice and I pick on the ref des shown, I go to the Properties… choice and get “Reference: ‘the ref des’” and “Layer: F.Fab”. I did find the “User defined” check box and that changed the reference designators that were on the F.SilkS layer, which are the ones I want to change.
–Thanks for your input, Larry

The official library uses the main reference on the silk layer. (The real reference field) If you have your own footprints then this might of course be different.

The land patterns/footprints that I produced were from PCB Libraries’ Library Expert Pro version (a free download that you have to register for and only works on Windows OS–footprints conform to IPC standards). I wrote on their forum that assignment of REF** and %R text were not in accordance with KLC rules. I got an answer back from the programmer person that, indeed, the assignment was backward and the next revision of their program would be coming out soon with the correction for KiCad included.