Github library invalid?

I have just installed Kicad on Win8 and my understanding is that there are basic libraries installed during the installation. Just to get familiar with the tool I created simple 3 component schematic. Wired it up then annotated it, then ran netlist. Then I ran CvPcb and this is where the trouble begins. I tried to load the libraries form Github and they are invalid. I only attempted to load two libraries from Github. Perhaps I’m suppose to do something in setting it up that doesn’t happen automatically when you install the program? I’m a new user so I can’t upload images for a screenshot, unless there is another way?

The first error I get says: “Configuration Error” No PCB footprint libraries are listed in the current footprint library table. Why would I get this error with a new installation?

I also found this thread My major frustration with KiCad + footprint talk

This is all very confusing to a beginner. Is there a step by step library configuration guide I should follow? Again, my confusion is that I thought there is a basic library installed during installation.



It can be confusing for experienced users as well… .:slight_smile: I use for hosting images, it is is easy to link to.

There are various things that can go wrong, depending on exactly which version you installed and which version (if any) you had previously. However, footprint libraries are configured in pcbnew, with Preferences->Footprint Libraries Manager.

Thanks bobc,

I got it going. I did a clean install on a desktop and it worked. So I uninstalled KiCad on my laptop to have a fresh (don’t think it mattered now) install then tried again…same problem. I looked at the configuration on the desktop and noticed the path for fp-lib-table and found the file on my laptop had nothing in it. Anyhow it’s working and now just learning the program.