Github-Freerouter busted?

I’ve completed a schematic capture and PCB layout.
I’d like to use the Freerouter from GitHub.
It installs and runs but it quits quickly!! I see no error message or indication of why this happens…
Would anyone have any ideas why I’m experiencing this?
Without launching a thread regarding pros and cons of auto routing (I’ve performed both in the past)… is there another autorouter I should try?
Copious thanks! :grinning:

Missing Java library? Freerouting plugin - failing - #9 by davidsrsb

Run freeRouting manually to check that it’s not your Java environment.

Yes, thank you … I can run the autorouter manually … I can load the DSN file from the pcb
into the autorouter, but the autorouter doesn’t do anything with it.
I’m wondering if I have some pcb setup parameters that are wrong and preventing it from
routing any traces …

Maybe submit an issue on the freeRouting site with the problematic DSN?

Errors in the board outline and stackup are likely causes

Yeah, make sure you pass DRC before attempting autorouting. freeRouting’s still a bit fragile with invalid input.

In particular if you do not have a closed outline in Edge Cuts, autorouting will not work. You can tell this is the case when the 3D viewer throws a warning, then assumes the outline is the minimum bounding rectangle of all the footprints.

I found the culprit but I don’t understand it.
I had used a Molex connector from the Kicad libraries and the associated footprint on two locations on my PCB, labeled J1 and J2.
Molex Mini-fit-jr 5569-06A1 2x03_P4.20mm_Horizontal.
I discovered if I were to delete one of the two connectors from the PCB, the auto router would run.
I tried pulling in a new library symbol and footprint from another part supply house, but to no avail. Same issue.
I wound up using a different connector because I got frustrated after chasing this for a day and a half😩
Any ideas why this happened?
Thanks again for the replies!

Report it on the freeRouting Github site. They’ll have to track down the cause to see if it’s anything to do with KiCad’s DSN generation.

Just „any“ idea (I do not know anything about freerouting):
Connectors sometimes cross edgecuts.
Not the pads, but courtyards and other.
As I said, just spoken into the blue…

I tried a minimum board with two of these connectors, all pins 1-1,2-2 etc and Freerouting just works fine.
This is a connector that can be expected to overhang the edge cuts.
Are your mounting holes safely inside the edge cuts outline?

I had that thought as well … One of my attempts to fix this was to make the board size much bigger than
needed so there was no chance of component overhang but the autorouter still failed to run.
As mentioned, replacing one of the minifit jr molex connectors with a different model connector fixed the issue.
(But now, I’ll need to work with two different connectors for the project :frowning: )
I’ll need to see if I can re-wreck my project by putting that second Molex connector back in and send the DNS to the autoroute page for analysis …

Yes … Waaaay inside!
I would think the design rules clearance would see this?
Thanks again :slight_smile:

OK … I just tried putting the original Molex connectors back into my PCB .
This time, the autorouter seems to work! Eyiee! >:-(

My suspicion is that you triggered a threading bug in Freerouting

@kc9kep Try using the command line option -mt 1 to force single-threading. Multithreading has failed in the past by creating clearance violations, and is supposed to have been recently fixed, but maybe not thoroughly.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.