Getting tired of routing method


#1

So, is simple. I’m totally tired of this routing suggestions. As an eagle user, i’m finding Kicad more and more inefficient every day.


#2

Simple solution : uninstall KiCad, install Eagle :wink:


#3

If you want more control over the routing process then do not use the interactive router. Set it to highlight collisions in the router settings. (under route -> interactive router settings. Changing these settings only gets active after restarting routing mode) This gives you a router similar to eagles router where you are in control.

You also might have the workflow a bit backwards. Why is the via there before the rest of the trace? (I know in eagle this is the normal way of doing things but in kicad simply press v while in routing mode and place the via that way.)

Also if you want the benefit of kicads powerful routers, except that you can not constrain them too much. In your case you would have gotten way better results when you do not fix the last segment that close to the via.

Another tip is to use smaller grid settings and the crtl key. Also helpful is the use of the interactive drag.


#4

Yes, but I’m trying to support open source :smiley:


#5

Thanks. I’ll try your suggestion. They’re not vias, are just some DIP holes. Hope it’ll get more controllable.


#6

As a user of Kicad for over 5 yrs now without any problems designing many boards both professionally & for my hobby I strongly suggest that you stop using it & go back to Eagle, a package that most of us stopped using because of Kicad’s powerful features!


#7

on some cases, it may help press / key
it will switch the orientation of the trace:

\____

‘’’’’’’’’’’\


#8

WHAT?!

(Post must be at least 20 characters. I will press the heart.)


#9

The [/] shortcut or key is called “switch track posture”

Usually I use the interactive router this way:

  • start routing, if I am not happy, go back a little and try to draw the track going some other way.
  • as I am happy while drawing, I press once in a while to keep saving the track progress.
  • while doing this process I pres the / key to see if the other track posture gives a better result.

#10

Well, you can always go back to Eagle :slight_smile: But before doing so, try this: open Interactive Routting settings, select ‘highlight collisions’ mode, uncheck “remove redundant track” and “optimize pad connections” and check “allow DRC violations”.

Cheers
Tom


#11

Are you using ‘anchor clicks’ to fix positions along the way? I don’t do that many boards but I seldom seem to experience getting tracks where I want them.


#12

If you want to use KiCad effectively, you have to stop trying to use it in the same way as you would use your other EDA package (ie Eagle). Each EDA package has its own strengths and weaknesses.

Take some time to get used to KiCad, and fiddle with it’s settings.
As suggested before, there are a bunch of different settings for the interactive router that can be tweaked.

Often you can also simply ignore such small things. Just connect a bunch of wires, and when you’re almost finished use the push and shove routing to smoothe the crincles out and clean up.

I absolutely love the push and shove function. It has enabled me to design compact 2 layer PCB’s that would have been completely impractical otherwise.