Gerbview rendering bug?

Nightly Application: gerbview
Version: 4.1.0-alpha+201605262346+6832~44~ubuntu14.04.1-product, release build

I am seeing odd behaviour when I load a single layer eg Front copper, where the tracks are not displayed.
If I load both Front and Back, the tracks are rendered properly, even though the Back layer is deselected.

The Geda Gerber Viewer handles the single layer correctly

Solved, I think.
For some reason the tracks are coloured black on a black background. Change the default colour and all is well.

Looks like a bug in the layer colour code when only one layer is loaded

Hm… can’t you change the layer color?

I do change it. The bug is that black is a daft default choice for the only layer loaded

It seems mine is remembering the color settings for the layers, or shall I say color/layer-slots as the viewer doesn’t put layers into the same spot, but depending on loading-order.