Gerber Viewer shows extra lines when in Polygon outline mode

Two layer board, front = signal, back is ground plane. Back is shown below.

When I look at the ground plane in the outline mode with the native “Gerber Viewer” I see unwanted horizontal lines (annotated with orange). I’m hoping this is just some artifacts from the viewer and not something that will cause errors in the final board. How could I tell?

When looking at the ground plane in the “filled” mode there are no traces of these lines (at any magnification).


Application: KiCad Gerber Viewer (64-bit)

Version: (6.0.0), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 24 2021 19:17:02
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

It’s a valid way to create a polygon with holes in gerbers. KiCad creates filled areas that way: the one and the same outline goes around the fill and to each hole, around the hole and back. All manufacturers and gerber readers should understand and handle it correctly because it’s valid gerber, explicitly mentioned in the official gerber documentation.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.