Gerber Viewer fails on kicad 5.1.2 [ubuntu]

I’ve just installed fresh kicad 5.1.2 from launchpad repo and found problem with Gerber Viewer.
It seems to me that it starts and immediately fails.
Here how it looks from application console:

I Use Ubunutu Mate 18.04.
May be someone can suggest me where the problem may be? Or what additional information should I provide?


This one seems to work always.

Can’t help (windows), but wait for more feedback on options for like a day and file a bugreport at anytime, but latest then.

Please include the information from About -> Copy Version Info in any bug report.
I just tried on my Ubuntu 18.04 system and GerbView works fine in 5.1.2
Do the other applications (Eeschema and PcbNew) work fine for you?

I compiled on Debian and have no problems. The command line doesn’t seem to take any switches but you could try running it from a terminal and see if it kicks out anything.

hermit@~:which gerbview

Tried this out on Ubuntu 18.04 64 bit and the first try brings up a choice selection box about using accelerated graphics. Could this be an OpenGL version issue?

1 Like

Thank You all very much for answers. Tried to launch same Kicad version on clean Ubuntu 18.04 and it works fine. May be, some problems with Ubuntu Mate

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.