Gerber Photoplot files

Hi,

I need to send some gerber files to fab. But it seems that they are made with Gerber 1x or photoplot? I don’t know.

The files are *.pho and *.rep

Is there some kind of conversion?

anybody can help me?

What exactly did the fab ask for or what was their comment? Note the X2 in the following graphic from the plot menu. Does that help you?

Sorry,

I think that I explain wrong.

I have an old PADS-Layout project. Job file and gerber files .PHO, .REP

The problem is I can’t view this files. Do you know some trick to convert this files or view it?

Thanks.

This really isn’t a KiCad issue, as such.

I know,

But I don’t where I can post this for help.

Pads apparently only costs USD 2999 per year. PADS Professional – Integrated PCB Design and Collaboration Flow | Siemens Digital Industries Software That is much less then USD 3000 per year :roll_eyes:

Maybe their free viewer works for you: PADS Standard/Plus Viewer

Alternatively, quite a lot of PCB manufacturers have an online preview of gerber files. You can try if any of them accepts your files, and if it works you can either opt to use that PCB manufacturer, or re-create the project in KiCad from screenshots taken, but that will take quite some manual effort, of course depending on the complexity of the PCB.

Have you tried using Pentalogix Viewmate? That is a free gerber viewer which is very popular. If your files are not confidential, why not post them and maybe one of us can at least recommend a viewer that seems to work.

Thanks for the tips.

I try JLPCB, and didn’t accept the gerber files. So, I try the Gerber viewers that you suggested.

Thanks.

The Reference Gerber Viewer is a free online viewer. Maybe it can view these.
.pho is an antiquated extension for Gerber files.
.rep I do not know, I doubt it is used for Gerbers.

I had the exact same problem a short while ago. Old gerbers created by PADS which I wanted to view, diff and import into KiCad.

Here’s how I did it. I used Gerbview to fix all files except the drill file, which I fixed manually. You can probably fix the other files manually as well, but I haven’t tried it.

Fix the gerber files (all except the drill file) using Gerbview

Download, install and open Gerbview 30 day trial (www.gerbview.com).

  • Go to the Settings tab and press Options.

  • Under Gerber: Select Units: Imperial, Coordinates: Absolute, Integer Digits: 1, Decimal Digits: 5, Zero Supression: None, Quadrant Mode: Multi Quadrant Mode, Keep original file offsets.

  • Add all .pho files using “Add Layer”. The .rep files are read automatically.

  • Check that the pcb is scaled correctly using the “Measure Distance” tool under Home. If it’s not scaled correctly: Press File → New project, Change the settings under Settings tab → Options, import the layers again. Try different settings and look at the .pho files in a text editor to detirmine what the units are and the number of digits. Look at the XY coordinates.

  • Go to the Conversion tab and press Save as RS-274X.

  • Select “Save to Multiple Gerber Files”.

  • Press the Settings button.

  • Under Gerber Output: Select Units Imperial, Numeric Format 2.4, Zero Supression None.

Fix the drill file manually

  • Edit drill file in text editor.
  • Before the % sign, add all the drill sizes. These can be found in the drlXX.rep file. The drill sizes shall have the same names as they have further down in the drill file (in this case T1 to T11). The drill size is specified in inches.
  • Remove all other information from the names of the drill sizes further down in the drill file. If the tool is specified as “T1F197S55”, then rename it to “T1”.

First rows before editing:
“”"""""
%
T1F197S55
X001Y00155
X00105Y00155
“”"""""

After editing:
“”"""""
T1C0.025
T2C0.028
T3C0.030
T4C0.037
T5C0.038
T6C0.047
T7C0.051
T8C0.060
T9C0.063
T10C0.071
T11C0.130
%
T1
X001Y00155
X00105Y00155
“”""""""

Move the drill holes to align with the gerbers

  • Download and open Gerbv. Binaries for windows can be found here: https://github.com/kitanokitsune/gerbv_for_win/archive/refs/heads/main.zip

  • Open the drill file.

  • Right click on the layer and select “Edit file format”.

  • Unselect ‘autodetect’.

  • Select Trailing zero_suppression.

  • Select inch units.

  • Select 3 digits.

  • Move the drill layer so that it aligns with the other layers. See: OSH Park Docs ~ Gerbv ~ Modifying Gerber Alignment

  • Export Gerber files and Drill files from Gerbv. It’s not necessary to export the Gerber files but it feels good to let Gerbv create the final files.

  • If the drill file contains both PTH and NPTH holes, move the NPTH holes to a new file using a text editor. Information regarding PTH/NPTH can be found in the drlXX.rep file. (this is not necessary, it’s just how I personally like to have it)

Resources

1 Like