Gerber export to PCB new: issue?

Hi guys,

while trying to write a perl script to convert the kicad_pcb to kicad_mod, I found a strange behaviour in kicad.

The steps to reproduce are the followings:

  1. Take a bitmap file of an image;
  2. Convert using bitmap2component to a kicad_mod
  3. Open the kicad_mod with a text editor and substitute the F.SilkS with F.Cu
  4. Complete the footprint and import that footprint into PCB New
  5. Export to Gerber
  6. Open with GerbView, it should match the PCB New version.
  7. File > Export to PCBNew
  8. Open with PCB new this file: only the outline are drawn.

I am wondering which is the issue: the gerber is ok.
Is this the expected behaviour?


Not a reply to your problem but maybe helpful anyways.
I found that bitmap2pcb is not really good for converting complex forms.
Have a look at svg2mod

I tried that one but caused me several issues, unfortunately.
The kicad_pcb to kicad_mod works really good, but the issue is from gerber to kicad_pcb when there are footprints imported in that way.
Maybe because they use fp_poly and it is somewhat limited to drawings. Anyway, the gerber looks ok and is also printed to board consistently, but not when re-imported.

IMHO, it could possibly be a bug, but not really surprising - how often does one go Gerber > PCBnew?

Maybe it is not so usual, but with RF designs and the perl script it is very useful.

I meant it more in the sense of encouraging you to test it some more and get a bugreport onto the bugtracker for this as I’m sure it can be useful for all kinds of things - so it better works :wink:

1 Like

you may find this thread useful

on other option would be custom pad shapes that is being developed

here some ideas


@Joan_Sparky would you be so kind to file a bug report for this? Are you able to reproduce the bug with a random logo?
If not, I could provide a gerber B.Cu.gbr (3.1 KB) file for the process.
I have seen that the wrong tracks have the G36* Gerber M-Code (from here they say G36: Turn on Area Fill).
The outline has G37* and is the only trace that is working (from here they say G37: Turn off Area Fill).
Hence, it is not able to export filled zones. Maybe they should be exported as segments (or something that can be easily converted to a footprint command).