Geographical Reannotate failing to sync between schematic and PCB

Hello All,
I am using the Geographical Re-annotate feature to change the PCB, and noticed that my schematic and pcb are now out of sync. I tried both:

  1. Within PCB Editor, Tools->Update Schematic from PCB
  2. Witin Schematic Editor, Tools->Update Schematic from PCB

Method 1 does seemingly nothing.
Method 2 very briefly shows a window (contents unknown since the window vanished almost immediately) and the schematic is left unchanged (and not in sync with PCB).

Thanks in advance for any help.


Application: KiCad

Version: 6.0.7-f9a2dced07~116~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-125-generic x86_64, 64 bit, Little endian, wxGTK, xubuntu, x11

Build Info:
	Date: Jul 26 2022 19:32:41
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.84.0
	ngspice: 36
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

Use Update PCB from Schematic. Can you get them in sync again?

Sadly no.
I tried both ways (from PCB and Schematic Editor)
One thing I notice is that there is a * on the very top of the PCB Editor Window’s Titlebar (suggesting that something changed and was not saved). However, I can’t save it and remove the “*” sign at the top.

Screenshot_2022-09-09_20-40-19

Another thing I notice is that (after these re-annotations) I can’t quit kicad from the main window. (File->Quit). The mouse, keyboard, and menus are responsive. But I just can seem to save and quit.

I tried this on two different computers (both linux and both Kicad 6.0.7) and both show same behaviors.

No, I meant File → “Update PCB from Schematic” from either PCB or Schematic editor.

This sounds weird. I don’t know, maybe there’s a bug somewhere. Can you reproduce the situation from some saved state so that you can attach the zipped project here and tell us the steps to follow so that we can try?

Sorry, I wasn’t clear.
By both ways, I meant precisely that (ie. in the PCB Editor, File-> “Update PCB from Schematic”, and the other way was in the Schematic Editor, File → “Update PCB from Schematic”). Irrespective of where you invoke "“Update PCB from Schematic”, the end results are the same: the PCB and schematic are out of sync.

I was having the same problem a few days ago. The “Update Schematic from PCB” was failing after a graphical reannotate - with the briefly flashing window, and inability to quit.

Rather than fight it, I tried the nightly build, and this flow is working fine there.
There’s probably a bug in the 6.0* build that is fixed in the nightly.
I’m hoping the nightly is fairly stable at this date - so far so good!