Front Panels; Hiding 3d Models (Virtual Components) in Step Export


I’m on Kicad 6. I’m trying to export a 3d model of a “front panel” designed in PCBNew (with matching schematic components by the way), so that I can import the front panel back into my main project.

I have a 3d model of my mainboard in the front panel PCB design. This is so i can match the holes up and make sure it looks good. I want to hide it when I export the front panel (File>Export>Step) so that it doesn’t bog down my 3d viewer when I’m working back on the mainboard, and so it doesn’t clutter up the 3d model with extra stuff.

There is this illusive option for "Virtual Component’ that is mentioned in the documentation. But my Footprint Properties Dialog does not have a virtual component option. It appears that the option radio select turned into a dropdown select, but “Virtual Component” is replaced by Other. There are a few other checkboxes (Not in Schematic, Exclude from Position Files, Exclude from BOM) but none of these do the trick.

So what I’m stuck doing is designing the front panel with the 3d model enabled. Then I have to go into each component and uncheck “show” in the 3d model. Then I export the step file, then I have to go back and re-enable (or just discard changes and reopen).

What I want is a simple way to turn off these special components, so they are not included when generating the Step export, so that I can import it back into my mainboard and show the front panel without the extra virtual components used to design it.

Any advice on how to do this with a better workflow? I’m considering having two footprints. One for the holes, and one for the 3d model. Then I can just search and delete the 3d model references but keep the holes. Is the Virtual Component concept gone now? The option to hide virtual components is still in the step export by the way.


The concept of “virtual component” was removed in v6 because it means nothing real. It’s an oversight that it wasn’t removed (and replaced) in the STEP export. I’ll file an issue for this.

EDIT: "virtual components" still exist in the STEP export dialog; nothing to replace that option (#10563) · Issues · KiCad / KiCad Source Code / kicad · GitLab

I’d like to further describe my workflow.

  1. Export mainboard 3d model.
  2. Import mainboard 3d model into front panel project.
  3. Export front panel 3d model (ignoring the mainboard 3d model)
  4. Import front panel 3d model into mainboard
  5. Repeat Steps 1-4 as design progresses.

And the cycle continues goes round and round. This workflow helps me to design both the mainboard and the front panel together, and view each on each project, so ensure it all matches up.

But I need to be able to

  • Show the component on the 3d renderer
  • Ignore the component on the 3d step export.

The concept of “virtual component” was removed in v6 because it means nothing real. It’s an oversight that it wasn’t removed (and replaced) in the STEP export. I’ll file an issue for this.

It did in fact have a purpose… As described. It’s a “Virtual Component” that is used for the design but shouldn’t be included on the exports.

Is there another way for me to show the component for design purposes but ignore it during the step export?

I might need to write a script to toggle the “show” for the 3d model on and off… Any advice on how I could do this? I’ve got some learnin’ to do. :slight_smile:

It had many non-related uses and the term “virtual” was ambiguous and non-descriptive. It’s an oversight that it wasn’t replaced in the STEP export dialog.

If I understood correctly, you have a footprint in the main panel for the front panel and vice versa, and they naturally must be excluded from each other to avoid them “multiplying” in the 3D models.

Logically these footprints should have options “Exclude from positions files” and “Exclude from BOM” checked. Maybe the fabrication attribute “Other”, too, but I think that one is originally meant for Gerber export for certain copper items. If these options would be in the STEP export, it would help you, right?


Either that, or a “show” column for the step file in the Edit Footprint Properties box.

I’m getting a bit ambitious, but I must also point out the missing “Edit Library Footprint” directly from the right click on a footprint… Drives me crazy having to go into footprint properties to get to that button. There is the “edit in footprint editor” but this is an instance based property and when you update the footprint your changes are gone. :end_rant

Thanks for at least answering my question and defining a potential solution for the future.

Ctrl+Shift+E should open the library footprint.

BTW, I have used FreeCAD + StepUp workbench which can load a KiCad board (the .kicad_pcb file). There it’s pretty easy to remove a component and export the result into a KiCad compatible wrl + STEP files. It’s a little bit more work but learning it may be beneficial for other needs, too. Then you wouldn’t need to modify the KiCad board/footprint temporarily. It may be a matter of taste which workflow you prefer.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.