Freeroute on Kicad 4.0.2-4


#1

I found a discussion about the latest version of kicad at enter link description here and it mentioned that if you copy the freeroute.jar file to the kicad binary directory it will work.

I’m using Linux Mint 17.3 Mate 64bit and this hasn’t worked, but, maybe I’m missing something.

Anyone have any ideas if this actually works and can elaborate on it a little?

TIA


#2

Personally, I run freeroute standalone. The export DSN /import SES options are available on the Export/Import menus, so the dedicated Freeroute dialog in Kicad really does nothing extra apart from launch Freeroute.


#3

I have previously tried using reroute standalone, but, had a problem.

It took a couple tries to get NetBeans and fr eeroute installed and configured and it did route the traces, but, when I made my Gerber files and sent them in the trace layer wasn’t there.

I tried a couple more times and went looking for somewhere else it may have saved the trace layer, but, never found it.

That was an earlier IS on a different computer. I guess I’ll try it again on the new system.

Any ideas what the problem might have been?


#4

yes, it works for me under kubuntu.


#5

Do you mean reroute from within kicad, the stand alone fr eeroute or maybe both?


#6

Freerouter doesn’t update the KiCad pcb, you need to export a “session” file from Freerouter then import that into pcbnew.


#7

Thanks everyone.

I did the netbeans/freeroute install on my new system and I can open my kicad dsn file and create a route. I then select to export a session file and this time I found it. It wasn’t saved in the folder that the project file I opened with freeroute, but, rather the folder that housed that folder. I was then able to import that into PCB New in KiCAD. I created some Gerber files and sent them to my fabricator to see if they will work and that will solve my problem.

However, I’m still interested in getting freeroute to run withing KiCAD. If my system gets corrupted or I go to new OS or something I have to reinstall my apps and Freeroute/Netbeans is kind of involved. Putting a jar file in the KiCAD directory would be simpler, but, maybe I don’t understand this correctly.

First, to launch freeroute within KiCAD to I need just the jar file or still need Netbeans, etc?

I ran $ whereis kicad and got
kicad: /usr/bin/kicad /usr/lib/kicad /usr/bin/X11/kicad /usr/share/kicad

So I put a copy of the jar file in each of these directories and it isn’t working (and I have netbeans etc on this system).

First I want to make sure I have the right jar file. I downloaded the zip file from https://github.com/freerouting/freerouting and extracted it and renamed the jar file that was in the binaries folder to freeroute.jar. That file is 3.8 MB. While I was doing the netbeans install, part of the procedure was to download and add a jar file called jh.jar. It is only 500 some KB, but, is this maybe the missing jar file?

Does Anyone has any thoughts?


#8

I just copied “freeroute.jar” binary to /usr/bin and it worked. I made it executable too, yet I haven’t thought about if that is really necessary.


#9

I got this to work on my Linux machine, but I can’t seem to find the correct place to put it on my Mac? Any ideas?


#10

it works on the mac if you put freeroute.jar in the Kicad/Content/MacOS/ folder
hope this helps.


#11

#13

Fantastic. Loaded freerout.jar into the Kicad binary folder. Ran like a charm. No need to compile or to go to Netbeans.
Has just routed a fairly complicated board - all integrated in Kicad.
Thank you.