FreeCad StepUp thinks Kicad origin not set (solved)

I’m playing with FreeCad with the KicadStepup workbench to get a 3d model that includes silkscreen.

It’s working pretty well, except the silkscreen graphics aren’t aligned. Probably related to this message I get when I open the Kicad pcb in the FC workbench:

I don’t know how to fix this. I’ve used View->Grid Properties and see this:


Also tried “Reset Grid Origin” on that menu, but it didn’t eliminate the FC warning.

I also tried the “Place origin point for drill files and component placement files”, but that didn’t help either.

Application: KiCad PCB Editor (64-bit)

Version: (6.0.8), release build

wxWidgets 3.1.7
libcurl/7.83.1-DEV Schannel zlib/1.2.12

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Sep 29 2022 00:21:26
wxWidgets: 3.1.7 (wchar_t,wx containers)
Boost: 1.79.0
OCC: 7.6.0
Curl: 7.83.1-DEV
ngspice: 37
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Click the Icon then click mouse where you want the Origin

Result after placing it…
Screen Shot 2023-01-06 at 06.43.45

Isn’t that the

“Place origin point for drill files and component placement files”?

Like I said, I tried that with no success. (yes, I saw the red cross hair after doing it).

Grid Origin: Place cursor where you want it, then press Spacebar

Grid origin and drill origin are two kicad different settings.
Please refer to kicadSteUp cheatsheet for FreeCad import settings and kicad pcb settings.

Yes, I have used the cheat setup and have configured as it indicated. I’m aware they are different–just trying what the poster suggested.

It doesn’t seem…
If you have set grid origin the warning should disappear… (not related to your issue)
Moreover you probably missed to export Silk screen unchecking the drill origin box, as suggested in cheat sheet.

So, if what I posted isn’t setting the grid origin, how do I do it (in Kicad).

The warning occurs before any exporting of dxf. Just when opening the pcbnew file.

1 Like

read what I posted in response

This is not the grid origin in kicad settings, but just an internal reference

Thank you! Got rid of the warning. Will try importing the dxf for silk again.

Confusing, though. If there’s no grid origin in Kicad, how is it the X and Y values are displayed at the bottom of the PCBNew window? And, why does it show up under View->Grid Properties

Ah, yes… I see that the Icon for Grid Origin was removed (only access to it is by the Main Menubar… ) Bad idea to remove it from Toolbar…

1 Like

Works perfectly!

Thanks Maui.

1 Like

It is not removed. If you look at the icon for the drill origin, you see a small black triangle in the lower right corner.


This means that it is a “fold out” thing, and you open a mini menu with different icons with a long click, and you can switch between the icons for drill or grid origin:


1 Like

Yes, correct - I’m getting old… too old…