FreeCAD Stepup Issue

I am using KiCAD 6.0.10 and trying to use FreeCAD 0.20 to create a step file and when I add the silkscreen, it appears to place the dxf info in the middle of the PCB not on the top or bottom where it should be. I have attached the generated step file for an example. I updated to the latest version of kicadStepUp-WB (10.16.5),

DEVKIT-9S12XE to PMBus Adapter - (927.7 KB)

do you have the kicad_pcb file to test?
without the source file it is difficult to debug it…
EDIT I made a test and found the issue… I’ll try to solve it

Here are the kicad_pcb and the front silk dxf files.

DEVKIT-9S12XE to PMBus Adapter - PCB_Vers.kicad_pcb (569.9 KB)
DEVKIT-9S12XE to PMBus Adapter - PCB_Vers-F_Silkscreen.dxf (669.1 KB)

Hi @waltersd
I found the culprit…
the name of the file contains ‘B_’ in PCB_Version which is used to assign the layer to Bottom (typically the name is like DEVKIT-9S12XE to PMBus Adapter - PCB_Vers-kv6-B_Silkscreen.dxf )
I could try to fix this, but I have to investigate default dxf filenames for different user case… the easiest is to change the dxf name from
DEVKIT-9S12XE to PMBus Adapter - PCB_Vers-kv6-B_Silkscreen.dxf
DEVKIT-9S12XE to PMBus Adapter - PCB-Vers-kv6-B_Silkscreen.dxf

As a side note I found that your pcb has a board thickness stackup of 4.69mm … are you sure you want this for your pcb? (IIRC there was a bug in previous release of KiCad about board thickness)

Sounds like this is an issue with “KiCadStepUp” in how it is handling the filenames. I think there still maybe a problem with how it handles the back silkscreen and displaying it partially into the PCB.

I did not want the board thickness stackup to be 4.69mm I wanted 0.062"

you need to fix it in kicad board stackup preferences menu

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.