FreeCad 0.20 and KiCadStepUp

Paging @maui
I have just upgraded on Windows to FreeCad 0.20
Is the KiCadStepUp plugin working 100% with the new version?
First try seems OK

StepUp is fully aligned with FreeCAD 0.20, which is an other great improvement in FreeCAD life cycle

4 Likes

Great news
KiCad users need to be aware that FreeCad 0.20 is now the official release

2 Likes

Got a new PC and trying to install everything.
I’ve a new Kicad V6.06 and a Freecad V.20
In FC, I’ve tried to load Stepup (via AddOn Mgr) and it appears to have downloaded some files.
There was no config process.

Having used Kicad 5.x and FC 0.18, I expected to see Setup in the WB list, but nothing. I saw an old post that says it doesn’t show in WB list, but will work. I’ve tried to open a abc.kicad_pcb file and get an “unsupported” message.

Is there any visual indication that Stepup is installed?

thanks
Barry

StepUp is a Macro addon installed via Macro>Macros
(note: you can Manually install it, as a last resort)

After installing, you Must Quit FreeCad, then re-start it

The Workbench is available via the Workbench dropdown and Menubar (shown below)

Via Menubar

Via Menubar

In the Macros Panel…

Please do not mix Macro and Workbench
StepUp started as a Macro but since at least 4 years is a Workbench.
It is installed through FreeCAD Tools Addon Manager as a Workbench

After a restart you should see it in the workbench list as kicadSteUpMod
and have a look at kicadStepUp-cheat-sheet.pdf

I’m not confused. FreeCad’s Macro panel (say’s Macro) and if you click ‘Download’ btn, the Addon panel pops up (same as if clicking Addon in the menubar)…

I don’t care what it’s called as long as I can get to it…

this is confusing… kicadSteUp is a workbench, not a macro

Operator Error. It’s working now as a WB.
For me, it does NOT appear as a macro

Thanks Maui
Barry

1 Like

Maui
I have a bit of a different situation. For a single KiCad component (SO239 RF connector) I have 2x 3D images. One for the connector body and another for the hex posts and screws.

In K, the 3D renders as expected with the connector about 10mm off the PCB supported by the hex posts and screws. When I use Stepup in FC, the connector is shown in the proper location, but the second 3D of the posts & screws does NOT appear.

My guess is that the second Step file is NOT loaded. This is not the end of the world problem as I can easily joing the conn and hardware in FC, then save a new combined Step file. I just wanted you to know about this. I can send you files if you wish.

Thanks for your work with Stepup. Much appreciated as it is a very valuable feature in aligning mating PCBs.

Barry

1 Like

@iabarry
please send me the footprint and the 3d model in step format, used for the fp… I will have a look
(even in PM here at forum if you prefer)

@iabarry
thanks for the files…
probably your FC settings are not as suggested by kSU, particularly you could have ‘Enable STEP compound merge’ checked…
If you uncheck that, your models should be loaded correctly by kSU in FC.

Still this is a user case I was used to handle… I have to investigate further what has changed (in OCC or FC) producing this issue.

I had to hunt to find “Enable Step compound merge”. I unchecked it and did another import and it worked correctly. THANKS!

Obviously this was my failure to RTFM. Could the install program have changed that checkbox automatically?

Are there other settings I should change?

1 Like

FC 0.20 has changed the place in which settings are stored… then at the installation could have started a clean profile compared to previous releases.

Moreover I didn’t noticed some initial configurations have changed and kSU didn’t check all Import settings as it did in previous FC releases …
I’m going to push a workaround asap

2 Likes

I have updated kicadStepUp WB…
it should now check if the import parameters are as the suggested one and prompt a message in case of mis-configuration…

The message can be silenced through kSU FC preferences.

4 Likes

In this case I’m glad I fell in the trap.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.