Footprints with Edge Cuts

Hello All,

I am pushing edge-cuts for the board outline

from FreeCAD.

On this board outline, I am trying to place a part (USB Connector) whose footprint also has some partial drawn edge-cuts.

I placed this part as best as I could on the PCB outline so the Edge.Cuts overlap, and the error I get is “Board Outline is missing or malformed”

I can edit one or the other to fix this, but I am wondering what the best procedure is when the part I am placing has it’s own Edge.Cuts.

Thank you,

BT
Version: 6.0.5-a6ca702e91~116~ubuntu20.04.1, release build

Edit:

  1. Other relevant thread I read:Footprints with PCB Cutouts . I was wondering if anything is new with Kicad 6 since this was posted.
  2. The highlighted line from “Datasheet” what I draw as a open contour on the footprint.

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the KiCad.info forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

The USB connector’s edge cuts are just for alignment right? Can you change the layer of those?

I could change the layer on the USB conn, and edit the PCB Edge.Cuts. (and that is how I solved it temporarily)
However, it becomes tedious to redraw the PCB outline everytime an edit (like moving the USB Conn) is made. Then I have to redraw the relatively complex PCB edge again.
It is just the non-closed edges. In some cases, where I added closed contours as edge.Cuts to the part footprint (like a mounting hole for example) that works well.

I haven’t tried this, but I wonder if you can turn that USB connector footprint into a regular footprint with a courtyard instead of an edge cut.

In real life the outline of a PCB is a single continuous form.
KiCad also expects the line and arc segments on Edge.Cuts to be a single continuous form. The endpoint of each line of arc, must be the start point of the next line segment or arc. Neither gaps nor overlapping sections are allowed.

This means you have two options: You can use te graphics on edge.Cuts in your connector as is, and then start adding line segments from the ends in that connector footprint, Or you remove (or move to another layer) the graphics on Edge.cuts in that connector and draw a complete outline on Edge.Cuts.

As Paul said, KiCad expects one continuous chain of lines, no overlapping or gaps. Whether this is good or not is a different matter. There have been plans for “real” outline which isn’t the same as the graphics in on layer. I have suggested ignoring overlapping lines, but the developers want a better (and more complex) solution.

Adding Edge.Cuts support to footprints was somewhat controversial even though it was a clear wish from many end users. The potential problems have been realized.

This Link to my Video should help

  • NOTE: I used v5.xxx in video - v6 has ability to draw Edge Cuts in the Footrpint Editor but, otherwise, the steps in video apply (just won’t need to mess with editing the file…)
1 Like

With such footprint I set its 0,0 point in the center of edge cuts line to be removed from the outline so placing is simple. I always have PCB main outline lines at rounded to 1 or 0.1 mm positions and I work with 0.1mm grid. My footprint would not contain those 2 horizontal segments ending its edge.cuts (at your picture) so I would draw the real outline lines perpendicular at line ends from footprint.