Footprints not showing in browser, nor chooser


#1

I am struggling with porting V4 projects to V5. I read a bunch of posts like (Installing multiple versions on Windows) and at least now I have a new set of config files. I can see the footprints with the editor, including the 3D shapes.

I think something is busted with the footprint browser and this post (Footprint viewer is empty) talks about V4, so I am at a loss.
The problem is that when I edit a schematic symbol and then try to view its footprint (clicked on button with red circle), the right window pane is blank.

I have more to add, but as a new user I am limited to one picture… more info coming.


#2

If I click on the 3D view, it shows fine. This tells me the tool knows where the models are.


#3

The footprint chooser also shows a blank pane.

Here is the install info, running on Windows 7 Professional:
Application: kicad
Version: (5.1.0)-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Environment:
KICAD_CONFIG_HOME=C:\Users\pescatore.GIT\AppData\Roaming\kicad5
KICAD_SYMBOL_DIR=C:\InstalledPrograms\KiCADV5\KiCad\share\kicad\library
KICAD_TEMPLATE_DIR=C:\InstalledPrograms\KiCADV5\KiCad\share\kicad\template
KISYS3DMOD=C:\InstalledPrograms\KiCADV5\KiCad\share\kicad\modules\packages3d
KISYSMOD=C:\InstalledPrograms\KiCADV5\KiCad\share\kicad\modules

I started this schematic from scratch in V5.
Any pointers would be appreciated.


#4

Looks like a rendering bug. If you place a footprint in pcbnew (any footprint) do you see it there? Do you see it under all modern/legacy toolsets?


#5

Yep, the footprints show up in pcbnew. They are also visible with the footprint assignment tool in the schematic by clicking on the footprint preview icon.


#6

please report this over at the bugtracker.


#7

I am also affected by this.

The “Choose Footprint” dialog shows a big black square after selecting a footprint, and then it gets drawn as soon as you move the mouse into the black area.

I can not make a screenshot of this, because as soon as the “Choose Footprint” window looses focus the footprint also gets drawn in the black area.

Application: kicad
Version: 5.1.0+dfsg1-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.64.0 OpenSSL/1.1.1b zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-4-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.64.0
Compiler: Clang 7.0.1 with C++ ABI 1002

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

Edit:
Bug report made as:
https://bugs.launchpad.net/kicad/+bug/1824505

Edit:
Added video of screen capture:
vokoscreen-2019-04-12_12-41-26.mkv (845.3 KB)

Most Footprints only show when the mouse enters the black area, but sometimes it is rendered immediately as it should, such as the SW_Cherry_MX1A_2.2u_Plate at 20s into the video.


#8

again the reminder: please report this as a bug over at launchpad.

There are also tools out there that allow to take a screenshot after some specific delay. Or maybe even better here: take a screencast that shows not only that the footprint is not rendered but also that any update to the preview area ensures it is rendered.


#9

I can no longer reproduce this problem. I replaced all the symbols that had been “rescued” from importing a V4 project to V5. Then I noticed I could see the footprints again. However, re-selecting the rescued symbols did not make the problem come back. Smooth sailing for now.
Thank you for reading.