Footprints not changeable in nightly


#1

Checking out r7855 i ran in to a problem.

When trying to change (or rather update) a footprint via Edit parameters->Change footpints, pcb_new refuses to do so.

Any ideas, why this happens?


#2

Does this happen for all footprints or just this one?
If it is only this one maybe pcb new does not like the new footprint for some reason.
If it does not work for any footprint then there is a bug in your kicad version.
(I like that it just says no. Without giving any reason.)


#3

Not likely.
I can insert the new(updated) footprint (hotkey ‘O’) and THOSE instances are changeable.
Btw, I updated the footprint to contain an additional text field on Cmts.User.

Will file a bug in the bug list. Just wanted to make sure this is not known already or that I didn’t violate any mystical, eternal KiCad laws…


#4

That might not be enough of a change for pcb_new to realize that the footprint differs from the current one.
(I think kicad only updates footprints that differ from the once it already uses. I think this is so that this tool does not create unnecessary work for the user because the text fields are all reset.)

The same problem happens if you add or change the 3d file path (or any 3d settings for that matter.)


#5

Think so, too.

If I change the footprint to one in a different library -> OK.
If I change the now changed footprint to the one I wanted in the first place -> OK.
If I change it “in place” -> No.

So I came to suspect the same, as you do: not enough of a change. But that’s a bug anyways, albeit maybe not high prio. And it worked in previous releases, btw. Ok, I cannot say this reliably, as I did major changes then.

I filed a bug and they already came back to me. Diagnose ongoing.


#6

Workaround: updating the footprint in the board while you are in the footprint editor. That works, also for 3D.


#7

In my opinion “No” is a bug. The message should be clearer and more informative.
E.g. “Nothing to be done”


#8

In the case at hand, there is something to be done, namely exchange the part because it was changed, no matter how and what and how minor or how significant in KiCad’s eyes. Changed -> replace. Full stop.

The “No” is a bug anyways, as you suggest.

Or, to say the least, not helpful. Is is true, however: KiCad didn’t do anything.