Footprints no longer snapping to grid when I drag them?

The previous behavior (going from Kicad 5 to Kicad 6.0.3 or so) went like this:

When I dragged a footprint, it would warp either the center of the footprint or the center of the pad to my mouse cursor. As I dragged it around, it would snap whatever I was dragging to the grid I had selected. This is what I want.

The current behavior goes like this:

When I drag a footprint, it does not warp the center of the footprint (or pad) to where my cursor is. Instead it just shifts the part along the grid I have selected, with the part itself staying completely off-grid.

When I bring my parts in from the schematic editor for the first time, the parts are dumped on the board view completely haphazardly without it aligning to any grid at all. As it currently stands, I would have to manually enter the coordinates of every part if I want them to be snapped to a particular grid.

Is there a way to restore the old behavior? If not, is there a way to automatically snap groups of parts to a particular grid?

Preferences / preferences / PCB editor display options / snap to grid… Half way down LH column.

There may have been a problem in 6.0.3. Currently Kicad is up to 6.0.7. It might pay to upgrade to the current version.

I upgraded to 6.0.7. The annoying behavior persists and nothing I can find in the preferences restores the old behavior.

maybe related: Wish: pcbnew - bring back the Move behavior from v5 as an option (#10937) · Issues · KiCad / KiCad Source Code / kicad · GitLab

you need two settings:

  • As @jmk says: Preferences / preferences / PCB editor display options / snap to grid: set to always
  • Preferences / preferences / Common / Editing (top right side): warp mouse to origin of moved object
2 Likes

Enabling “Warp mouse to origin of moved object” restored the behavior I wanted.

Thanks!

2 Likes