Footprints and 3D Models are not visible in 5.1.4

I have KiCad 5.1.4 installed on my Windows 7 system. Whenever I try to add a part and look for its footprint or 3D model, I am unable to see them. Instead I get the following message,

If I browse through the Footprint Library Browser, I can see the same footprint there. If I try to open the 3D view, there will be just the PCB without the actual 3D shape.

Below is how my paths are configured and everything is in the right place as I confirmed via the file explorer. What’s wrong here ? Am I missing something ?

KICAD_PTEMPLATES - C:\Program Files\KiCad\share\kicad\template
KICAD_SYMBOL_DIR - C:\Program Files\KiCad\share\kicad\library
KICAD_TEMPLATE_DIR - C:\Program Files\KiCad\share\kicad\template
KICAD_USER_TEMPLATE_DIR - C:\Users\AYGENT543\kicad\template
KISYS3DMOD - C:\Program Files\KiCad\share\kicad\modules\packages3d
KISYSMOD - C:\Program Files\KiCad\share\kicad\modules\

The message seems to indicat that the footprint does not exist in your installation. If you add the symbol as is and try to create a pcb does it give you an error message? If so it might be because you had v4 installed in the past and KiCad still points to the old online footprints. If that is the case then this could help you out: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup

I think I had a 4.x version before. It’s only recently that I started using KiCad and I simply downloaded and installed the latest version available that time.

So would a clean installation work after I manually remove any remaining files and directories ?


If this is the cause of your problems then yes. See the document i linked. It should give you the instructions to find out if this is indeed the cause of your problems and it also details how to solve it.

1 Like

I have the same problem. First I tried Uninstalling and reinstalling KiCad which did not fix it. The uninstall must leave files in the …AppData/Roaming/kicad directory. Then I found this post and deleted the fp-lib-table file. It did ask to use a new default table but it still did not show the 3D bodies for the kicad parts.

Deleting the folder …AppData/Roaming/kicad and reinstalling KiCad seems to have resolved the problem. Thank you for the post it helped a lot!

I had the following problem on Windows 10:
No 3D display in 3D viewer and Footprints.
I solved the problem as follows :

  1. uninstall kiCad
    2 remove all kiCad keys from windows registry with regedit
    (so all outdated kicad installations…)
  2. new kiCad installation with automatic registry-key/path-installation.
    and it works fine…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.