Footprint wizards missing in Kicad Nightly, wizards from Github don't work

Hi,
it’s been 10 months since the last time I was able to use footprint wizards. It started with the wizards causing the whole KiCAD to instantly crash. Then, after 7 months, it was supposedly fixed. However, it seems to me that the fix included removal of all of the wizards from Kicad package.
https://gitlab.com/kicad/code/kicad/-/issues/3910
There was also one bug file by Paul Kenyan on Launchpad regarding the same or similar problem in first half of 2019.

My KiCAD installation tries to search for the wizards in these 4 places:
/usr/lib/kicad-nightly/share/kicad/scripting
/usr/lib/kicad-nightly/share/kicad/scripting/plugins
/home/msboss/.config/kicadnightly/5.99/scripting
/home/msboss/.config/kicadnightly/5.99/scripting/plugins
However, all of these folders either do not exist at all or are empty.

I am using Ubuntu MATE 20.04 (Focal), KiCAD is installed using official PPA (not the legacy jsrenaud one). I also tried to remove kicad and every kicad-related package using apt purge and then install it back. It installed without the wizards again.

So I went on a hunt for wizards. On official KiCAD GitHub, there is a repo with the wizards. Is it really official repo? There is only 14 commits throughout the whole history.
https://github.com/KiCad/kicad-footprint-wizards
OK, so I tried to download the most recent version and put it into the directory it is searching for in my home directory. The result is that it sees the wizards, but they are not useable.

It tells me this in Messages in the dialogue “Footprint Generators” in section “Not loadable python scripts”:
/home/msboss/.config/kicadnightly/5.99/scripting/plugins/fp_test.py
Skip subdir /home/msboss/.config/kicadnightly/5.99/scripting/plugins/pycache
/home/msboss/.config/kicadnightly/5.99/scripting/plugins/FPC_(SMD_type)_footprintwizard.py
Skip subdir /home/msboss/.config/kicadnightly/5.99/scripting/plugins/.github

If I try to launch any of the generators, I get an error:
image
So, I would say that these wizards ar enot compatible with KiCAD nightly.

OK, so just right now I found out that the GitHub repository is possibly not mantained and now, the official repository is on GitLab? Probably. But someone could have been so nice to write it on the Github repo. Something like “This is legacy code, do not use. Go to Gitlab.” would have been helpful. So, half an hour spent with good fun. Let’s try the Gitlab wizards.

https://gitlab.com/kicad/code/kicad-footprint-wizards
Fine, I tried this repo. It is even older than the GitHub one. Not even one of the 3 branches has a working wizard.

OK, so I installed stable KiCAD from system repo. It has footprint wizards. And they work. Tried copying them to the nightly KiCAD. Same error.

And that was pretty much all I can withstand for today, I will probably have to use stable KiCAD for making new footprints. So, here is the question section:
Has anyone successfully used footprint wizards recently on Ubuntu using the nightly PPA?
Does anyone else have the same problem with missing scripts?
Where can be the footprint wizards found?
Is the GitLab repo the official one or the Github repo? GitLab has 3 branches, but GiHub has the most recent commit.
Can anyone help me, please?

My KiCAD version:
Application: KiCad

Version: 5.99.0-unknown-cf2dd0bd38~106~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-58-generic x86_64, 64 bit, Little endian, wxGTK, mate, x11

Build Info:
	Date: Jan  9 2021 10:17:24
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.3.0
	Curl: 7.68.0
	ngspice: 31
	Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
	KICAD_SCRIPTING=ON
	KICAD_SCRIPTING_MODULES=ON
	KICAD_SCRIPTING_PYTHON3=ON
	KICAD_SCRIPTING_WXPYTHON=ON
	KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
	KICAD_SCRIPTING_ACTION_MENU=ON
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

Are these the same wizards that come with the KiCad installation? If they are then you might want to make a bug report especially if you get a crash.

I can’t say they are the same since my KiCAD installation comes with no wizards.

They are probably missing in nightly because they don’t work. No one update them to work with nightly. My guess is kicad devs are waiting for the nightly to stabilize before fixing them.

1 Like

3 months ago, they were supposedly fixed for both 5.1 and 5.99 branch (and supposedly verified that they work). 9 days after the fix was done, I found that my wizards are gone.
https://gitlab.com/kicad/code/kicad/-/issues/3910

I don’t believe that someone thought “Hey, it was fixed after 7 months of being unusable and it was working for over a week, let’s break it and watch what happens”.
I still want to believe this was some mistake when preparing the packaging script and not an intention…

In the last months there was a lot of refactoring done that was breaking python api every other week. I maintain a plugin and I know it from experience. So it wouldn’t be surprising if nobody bothered maintaining the wizards. But it could be a packaging mistake too. Either way there should be an issue for this on gitlab so it’s tracked by devs.

1 Like

Filed.

1 Like

It was found out that the footprint wizards are indeed present in the package and are placed in
/usr/share/kicad-nightly/scripting/plugins/
So, it seems that the wizards work properly (I tried QFN, QFP, SOIC and FPC), however someone moved the folder to a new place, but forgot to change the search paths in KiCAD. As it seems, the paths are not configurable via GUI.