Footprint wizard hasn't available any Footprint Generator

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

I’ve installed Kicad this week in Windows and Linux(vs: Zorin OS(based on Ubuntu)) and in both the Footprint wizard has not available any Footprint pattern.


Kicad doesn’t let me write a path for the footprint generator files, and Python Modules are updated.

And when you search the footprint patterns in the Gitlab’s code doesn’t appear in the folder with the others components.

Then, I don’t know if it is a bug or I have to write the path of the footprint patterns.
Please, help

Hmm, that’s weird,
I get the same from ** Footprint Editor / File / Create Footprint**


The Update Python Modules button also does not seem to change a thing.

I’m running Linux mint and these are the footprint wizards and their locations as installed by KiCad.

paul@cezanne:/usr/share/kicad/scripting/plugins$ ls -hl
total 184K
-rwxr-xr-x 1 root root 1,9K Mar 21 18:21
-rwxr-xr-x 1 root root 6,0K Mar 21 18:21
-rwxr-xr-x 1 root root 5,1K Mar 21 18:21
-rwxr-xr-x 1 root root  28K Mar 21 18:21
-rwxr-xr-x 1 root root 6,6K Mar 21 18:21
-rwxr-xr-x 1 root root    1 Mar 21 18:21
-rwxr-xr-x 1 root root  25K Mar 21 18:21
-rwxr-xr-x 1 root root 7,8K Mar 21 18:21
-rwxr-xr-x 1 root root 4,7K Mar 21 18:21
-rwxr-xr-x 1 root root  14K Mar 21 18:21
-rwxr-xr-x 1 root root 8,8K Mar 21 18:21
-rwxr-xr-x 1 root root 6,3K Mar 21 18:21
-rwxr-xr-x 1 root root 7,7K Mar 21 18:21
-rwxr-xr-x 1 root root 8,8K Mar 21 18:21
-rwxr-xr-x 1 root root 7,6K Mar 21 18:21
-rwxr-xr-x 1 root root 6,1K Mar 21 18:21
-rwxr-xr-x 1 root root 6,7K Mar 21 18:21
Application: KiCad Footprint Editor

Version: 6.0.4-6f826c9f35~116~ubuntu20.04.1, release build

	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.13.0-27-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: Mar 21 2022 17:21:29
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.81.0
	ngspice: 31
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:

Interesting, same happens here, Linux KiCad 6.0.4.

But if you enter the footprint editor via the PCB editor, then the wizards are available. Sounds like a bug.

1 Like

I wanted to open an issue for this on gitlab, and discovered it was already reported last week:

1 Like

It turns out that it only happens if the PCB Editor has never been opened in the session. Once it has been opened, and even closed afterwards, the generators are available. Which is why the bug wasn’t noticed sooner.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.