Footprint with edge cuts

Hello

I am trying to make a footprint to insert a pcb (vertical) that has connectors that is welded on the motherboard, but when it comes to emptying the edge cuts layer it is not shown in the 3D viewer.

I have done two tests in case the drawings are not properly closed (in red), but I get the same result.

Possibly I am doing something wrong, I have searched the internet, I have consulted the forum and watched videos, but I do not do it correctly. Can anyone guide me on how I can do this? So far I had only made a few SMD footprints.

Thanks a lot.

Best regards.

Hello

I have continued to test.

I have removed the emptying that I draw and now, if I see the emptying in the edge cuts layer.

I have tried to do my emptying with complete drawings, instead of using lines and arches, but I get the same result.

It is confirmed that I am doing something wrong, but I do not know the reason.

Best regards.

All shapes in Edge.Cuts must be fully continous and closed, even one small difference between line endpoints cause a problem. I bet there’s such problem in the “plus” shape.

There’s another problem with edge rendering in the 3D viewer. KiCad doesn’t render a hole, but thinks that a closed shape is a board outline, even though it’s pretty much self-evident that if in a footprint there’s something outside that shape, the shape itself is an inner hole. But for some reason I don’t see this in your screenshots. What KiCad version you are using?

The visual representation you see when doing a FOOTPRINT is NOT an edge cut. It is a representation of what the pads and silkscreen will look like when you place them on a larger PCB. Otherwise, a pcb would be a collection of “tiles”, not continuous. Hope that makes sense.

I’ve not tried to make edge cuts in a Footprint, only on a PCB.

I suspect you have Line connection errors, as @eelik indicated.

One of the better, recent improvements to Kicad is having ability to make Edge-Cuts in the Footprint creation panel (thus, no longer needing to edit the Text file and manually change layers).

Works perfect - screenshots show:
• Edge-Cuts in the Footprint panel

• Footprint placed on a PCB. Naturally, the PCB, itself does not have Edge-Cuts drawn since I included them in the Footprint

• Footprint with deleted Edge-Cuts, then placed on PCB and added Circular Edge-Cut (drawn on PCB)

It is confirmed that I am doing something wrong, but I do not know the reason.

+1 for eelik: not exactly closed shape.

Additionally in your last picture you created the cutout with two overlapping shapes: this is not allowed. (see arrow at my picture).

Also its not allowed to build a cutout with several shapes attached together (so they share a edge-line). picture also attached.

remark: picture upload not working - maybe later

Hi

Thank you all for replying.

I do not think it is a problem that the polygons are not well closed, because to avoid this and that the lines were straight, I made the drawings using coordinates. I don’t know why or if I’m doing something wrong.

I have continued doing tests and eliminating the figure above and making it straight, avoiding the intersection (they really did not intersect, but I have made the simplest drawing), it comes out like this.

Possible my mistake or bug?

Surely I am doing something wrong.

Attached the data of my system.

Application: KiCad Footprint Editor (64-bit)
Version: (6.0.7), release build
Libraries:
    wxWidgets 3.1.7
    libcurl/7.83.1-DEV Schannel zlib/1.2.12
Platform: Windows 10 (build 19044), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
    Date: Jul 26 2022 02:49:38
    wxWidgets: 3.1.7 (wchar_t,wx containers)
    Boost: 1.79.0
    OCC: 7.6.0
    Curl: 7.83.1-DEV
    ngspice: 37
    Compiler: Visual C++ 1929 without C++ ABI
Build settings:
    KICAD_USE_OCC=ON
    KICAD_SPICE=ON

Thanks!

Post your Files/project…

Hello again,

I’ve removed the lines and redone them and now they seem to look good, at least in this figure.

Thanks

Hi

Attached the component library

PCB_MODULE.kicad_mod (3.5 KB)

Thanks!

Hi

I got it to work, I really don’t know how.

I eliminated the lines, I created them again making the points coincide (marker comes out) but it still did not appear in the 3D viewer, I have tried to modify the coordinates by hand and it has worked.

1 Like

I guess you connected the arcs to the line endpoints now, which wasn’t the case before. Unconnected arcs are a somewhat common problem. They look connected, but rounding errors can create tiny invisible gaps.

There was an endpoint mismatch, at least one.

image

It was perfectly connected, but I recreated the lines and it worked, I don’t know exactly what the problem was.

Possibly, but it all seemed right. Insert the coordinates by hand as well.

Doesn’t DRC tell you where the mismatched points are? (Or is that a 7.0 feature?)