Footprint which is only in SilkScreen can't be deleted

I updated KiCad to Version 6. In my projects I have some Graphs in the Silkscreen for Version Logo and so on. I added them by simply adding an footprint in the .kicad_pcb (it’s not in the schematic).
Here is an Screenshot:
No the problem is I can’t delete them. I even can’t select them. Do you have any idea how I can delete this footprint? In the old version this was no problem.

Best regards

Do you have Footprints turned on in the Selection Filter at the lower right of your window?

1 Like

yes I did.

Even if I turn on all layers
There is no way to select it. It’s behaving like it wouldn’t be there.

what happens if you:

  • set the selection-filter to “only footprints”
  • locked-items also checked (enabled)
  • than “CTRL+A” to select all footprints on board
  • than “delete” to delete all footprints → gets the footprint in question deleted?

You could also attach the complete archived project in this thread - so we could look into this bad footprint ourselves.


Great! This solved my topic! In the selection area “locked items” was disabled…Thanks for the great support!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.