Footprint/track dimming behavior (net highlighting) which I do not understand

Thanks to this forum I recently discovered the net highlighting capability in version 6.0.

I think that button works pretty much as desired when I select a net on the schematic. One thing that happens is that the footprints and tracks (which are not on that net) are dimmed. So far so good.

But if I exit that function (lets say I now hit the top right button in the schematic toolbar to select items) the footprints and tracks do not return to normal brightness. I can perform a fair amount of editing without the brightness restoring to normal. Actually it also seems that the previously-highlighted nets tend to remain highlighted even after I perform other actions. But it seems that if I click on a power port in the schematic, that restores the brightness to normal.

I had not previously been using the net highlighting function so I do not know if this is a new modus operandi. Is it my brain that is dim or is this a minor bug?

Application: KiCad Schematic Editor (64-bit)

Version: (6.0.0-rc1-119-g126563c839), release build

wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19043), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Nov 22 2021 12:00:10
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

Don’t directly exit the tool. Click once in the white space in eeschema canvas. That clears the net selection.
IIRC same was case in 5.1.x too.

Net highlighting remains active until turned off (there are a few ways to turn it off, including highlighting empty space, or using the hotkey Ctrl+` in the PCB editor, or right-clicking something in the PCB editor and choosing Clear Highlight from the Net Tools menu)

The idea is that you may want a certain net highlighted while you do some other operations (moving things around, drawing new items, etc).

With my setup it is black space! :slight_smile:

Thank you @craftyjon and @apurvdate for correcting the error of my ways…

EDIT: Yes I see that clicking on blank space indeed clears the dimming and highlighting.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.