Footprint pads have other size in pcbnew and pdf print


#1

Hello,

I have modified TSSOP package to have 14mil pads, and connected them via 14mil traces. This is because I am etching the board myself, for quick turnaround prototype in my company.

However… In the pcbnew and in the 3D viewer I see pads and traces correctly, as 14mil (no width difference between track and pad). But when I generate the PDF for printing, the pads are visibly thicker. This caused shorts in our non-perfect DIY etching.

Not sure if bug (or if known one). After some mocking around I noticed that SOME pads are the way they should be, while some are not. If needed I can disclose the files privately. Maybe I made a mistake somewhere, but it should still be a bug, because in pcbnew/3D it looks “correct”, while in PDF output it does not.

Due to limitations for new users, here is imgur album: https://imgur.com/a/2IGwD49

Thanks


#2

Which tool did you use to get your pdf? Print or plot?
If you use the former: Did you by any chance have mask enabled within the print dialog? (mask is typically slightly larger than copper, all layers are printed on top of each other.)

Please also add your kicad version information (help -> about kicad -> copy version info)


#3

I used Print, only B.Cu selected. No technical layers, accurate scale 1, didn’t need to change other settings.

Application: kicad
Version: 5.0.2-bee76a0~70~ubuntu18.04.1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Platform: Linux 4.15.0-55-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.65.1
OpenCASCADE Community Edition: 6.9.1
Curl: 7.58.0
Compiler: GCC 7.3.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#4

Well with print you depend on your operating systems pdf creation. But i doubt this is the issue here. I still suggest to use plot to get a pdf. (print is useful if you need to scale x and y direction independently. Which is needed for high accuracy on home printers.)


I further suggest updating to 5.1.2 (or within a few days 5.1.4) as 5.0.x is no longer maintained and has quite a few known bug. I think there was a bug that looked quite similar to what you reported here.


I tested plot under 5.1.2 and it gets me tracks and pads of the same size if they are the same in kicad. I did not check if the absolute size is correct.


#5

Noted. Using plot instead of the print did not help the problem, but I will upgrade to 5.1.2 (Or wait for the 5.1.4). If the problem will appear again, I will update the post


#6

Try posting now it now.