Footprint not recognizing tracks _PCB

I just finished my PCB placement and rename quite a few components.
While doing that I deleted a component. no worries I used the Update PCB from schematic’.
So now its importing all the components and it also changes the name of the components I modified.
How do I import only one components in the PCB without changing any of the text with the components already in place ???


What is your OS and which version of Kicad are you using?

Not clear for me what rename means. Do you change references or values?
Not clear for me - do you change it at PCB (I have never tried) or at schematic (I used to do it sometimes).

According to my experience components that were at PCB and were not changed in any way (neither at schematic, nor at PCB) were never touched when I used Update PCB from schematic.
So if in your case Update imports all components once more it is surprising for me.


I am using Kicad 6 on windows 10…
To better explain, I placed my components in Schematics using the default name.
Now transfer to PCB to place my components then rename the components to the desired values.
Realized I had deleted a components I go to update PCB from schematic ( I tried all possible options) all the components I renamed comes back as a copy, and the components I have renamed (reference and values) reverts back to their default naming.
I would like to import that single component only, and that my custom naming does not change


In PCB editor you can use Tools / Update schematic from PCB to get your schematic to match your PCB, then try update PCB from schematic.

Still not clear: Rename at schematic or at PCB?

If you renamed at PCB then everything works correct - the program task is to update your PCB according to schematic so it does what it is expected to do.
If you renamed at schematic then I don’t understand what is going on.

I don’t use V6 yet so may be something works differently that I’m used to.

The default workflow is to edit the schematic and then propagate the changes to the pcb. So, you should change the component properties in the schematic.

If for some reason you want to edit them in the pcb, you have to use Tools → Update Schematic from PCB.

If you have added footprints manually they aren’t recognized by the schematic <–> pcb connection. Then you will get “copies” when you update the pcb from the schematic.

Maybe you should read Update PCB from Schematic's match methods.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.