Footprint not found - kicad inserting characters into footprint field

I have a number of symbols with this error.

Error: Cannot add C27 (footprint ‘Footprint: Capacitor_SMD_C_2220_5650Metric_Pad1.97x5.40mm_HandSolder’ not found).

The characters 'Footprint: ’ are not in the footprint field in the symbol. Those characters are being inserted somehow between schematic DRC and PCB update.

Anyone have any advice? I don’t know a workaround for this either.


Did you know that if you have “Show Name” checked in the symbol properties, it inserts the name not only in the field on the symbol, but also breaks the the footprint link?

Maybe there’s a good reason for that, but… IMO that’s real dumb.

This sounds like a bug, could you post your KiCad version (Help->About->Copy version) and maybe some screenshot to make it clearer ? Thanks

Along with @der.ules suggestion, which Fields in the Symbol Properties “show” and “show name” do you tick to break the footprint link?

Sure. Version Info:
Application: KiCad PCB Editor x64 on x64

Version: 7.0.1, release build

wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 11 2023 03:41:46
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

Here’s the box that caused/fixed the issue…

I’m unable to create this fault using the same symbol, value and footprint, BUT, I am using 7.0.5 and Linux Mint.

Maybe a bug in 7.0.1 that has since been corrected???

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.