Footprint library missing on Kicad 6

I have just upgraded to Kicad 6. First three attempts left me with no symbol or footprint libraries.
After clearing all remnants of Kicad 5 out, I tried again and this time got the symbols but no footprints.
The footprint directory is present, but the footprint library was empty. The option to add a global library was greyed-out when running the program for the first time.
I have successfully added one library manually. How do I add the other 134?

Greetings @IanB

There is another thread discussing this problem here.

The instruction paragraph in the last post should cure the problem. It involves re-installing 6.

I would have worded this as “It involves resetting KiCad settings to the post-installation state.” The instructions you link to aren’t actually reinstalling the entire KiCad package, rather just returning to square zero for the configuration.

In my case (Mac, OS), all the Library Paths are correctly set, as seen in screenshot (I reset them when I upgraded Kicad and OSX Monterey).

However, when Creating New Projects and/or Opening Existing projects, the Model Path does NOT reflect the Path Field correctly.

I’ve Editing this field (add 6 and _DIR). You can see they are correctly set, though.

I went a step further for a Test and reset the Path for KICAD6_3RD_PARTY to my models folder but, it didn’t help.

I also put some models (step and wrl) in that folder but, they don’t get loaded… The Field (with bad path) for my model path always remains the same so, I now enough to place the 6 and _DIR into and all is happy for the specific model/footprint…

Screenshots show what I believe to be correct paths (I never had a problem until v6) and Manual Edit for each project :nauseated_face: