Footprint library browser - setting to keep same scale on browsing

When using the footprint library browser to select a footprint, the preview pane automatically rescales to fit the entire footprint (including the text for the footprint name) in the pane. This makes it unnecessarily difficult to spot differences between similar footprints. I would like the scale to not automatically change when selecting different footprints.

I know there used to be a setting for this somewhere, but for the life of me I can’t find it in kicad 6.0.0. Has this been removed?

1 Like

I think it changed to be a dropdown zoom setting, one of which is auto:

If you change it to another zoom setting with the dropdown, it seems to stay at that zoom setting. However zooming with the scrollwheel seems to set it back to auto – not sure I like that, but I guess it works.

2 Likes

Thanks, not sure how I missed that.

Anyway the behaviour there seems a bit odd. Manually zooming with scrollwheel doesn’t always set it to auto - if you land exactly on one of the dropdown items, it will select that, and then changing to another footprint won’t revert to auto. But if you zoom to an intermediate size, the dropdown is set to auto and then changing to another part results in the scale being recalculated.

Seems like a bug to me.