Footprint Library browser Hangs

I have recently updated to 5.1.9, and now I’m finding I can’t assign footprints to symbols by editing the symbol properties - Kicad hangs as soon as the Footprint Library browser opens. This happens in the symbol library editor and in the schematic editor.

I can add footprints using CVPCB. But thats a terrible workflow for anyone used to using atomic parts like me.
I can also edit the footprint by typing or pasting the library and footprint name in the footprint field.
The issue only occurs when trying to use the footprint browser.

Everything was working fine before the update to 5.1.9 ( from 5.something), and I haven’t added any new libs since the update.
Anyone got any suggestions?

How are you launching the Library Symbol Editor?

What OS are you using?

Symbol editor is being launched from the main Kicad menu, as is the schematic editor
OS is Win 10 ( sorry, should have said in OP).
I have the digikey libraries installed along with the Kicad ones, but they worked fine previously.

Can you check if you still have libraries with direct github access (via the github plugin) in your lib table (should not be the case with version 5 as we dropped support for these libs but it was the default in v4 so it could be left over from a previous installation).

If this is the case then a sudden hang can be the result of an internet issue (or a change on githubs side of things).

Note: the fact that cvpcb works would however make this unlikely (can however still be the case if the internet is slow and your testflow means cvpcb has more time before you need libs than your other tests)

I can’t see any references to github in the library paths. There is still a github environment variable set though - I can’t delete it.

The variable does not do anything if it is not used. So at least we know it does not come from this.

Just found opening the footprint library browser from the footprint editor also hangs Kicad. So it would seem something is specifically upsetting the footprint library browser.

Delete all the libs and see what happens?

nvm: tried removing the digikey libs: still hangs
changed path to non-existant dir: still hangs

Weird thing is I can still open and edit footprints in the footprint editor, its just the browser that crashes

Getting late here - will try full reinstall tomorrow.

First uninstall /reinstall : problem persists.
Second uninstall + manually delete the kicad folder in …\appdata\roaming\ then reinstall,

  • problem fixed.

So something in the user settings in …appdata/roaming/kicad was not playing nice with the new installation, and hadn’t been updated by the new installation automatically.

Solution is to delete the Kicad folder from …\appdata\roaming\ then reinstall

I have a similar, but much worse problem with Eagle - I have to keep on deleting a folder from …appdata/roaming/eagle, otherwise it wont run at all. And thats every time I have to run Eagle.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.