Footprint Library Browser button doesn't appear

Problem:

Footprint Library Browser button doesn’t appear and the text is gone
if I resize the window, the button appears but the text is not really readable.
Is there a way to fix this?

System:
Linux Mint Cinnamon 20.3
Kicad 6.0.6-3a73a75311~116~ubuntu20.04.1
wxWidgets 3.0.4Unicode and Boost 1.71.0
Platform Linux 5.4.0-122

Did you click on the books (the three stripes) at the end of the column with the description?

the 3 books are not there, I have to resize the window everytime, before the 3 books appear.

I found a screenrecording with the same issue

https://gitlab.com/kicad/code/kicad/uploads/29e079a0060afa2cab706dc6bd5fa01d/simplescreenrecorder-2020-10-20_16.40.21.mp4

Click on anywhere on the footprint line in the Value (Wert) column and the books should appear.

there is no problem with Windows or Manjaro

but if you look at my screenrecording, I just made,
you can see its only working if I resize the window

Has this problem just happened or has it always been so?

I use this version on Mint Cinnamon 20.4 and have never had a problem.
The only difference is I use the English version.

Application: KiCad

Version: 6.0.6-3a73a75311~116~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-122-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Jun 20 2022 15:49:56
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.83.1
ngspice: 36
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

every thing the same

I changed all language settings to USA (Linux mint) and kicad to english.
Still the same problem on two different PCs (new AMD 5600G and an old intel xeon)

we just switched from windows to linux mint
there was no problem with windows or with manjaro (VM)

Application: KiCad

Version: 6.0.6-3a73a75311~116~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-122-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Jun 20 2022 15:49:56
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.83.1
ngspice: 36
Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

it seems to be a problem with the linux mint theme

I changed the controls to Adwaita

thank you for your responses

1 Like

Sorry for no response earlier, been out all day.

Glad the problem solved.