Footprint Libraries misspelled?

Hi, I am a quite new KiCAD User, I changed from Eagle and I found KiCAD much more better and faster, nice program. My System is a debian Linux (buster) and I installed KiCAD from the debian distribution repository.
I created my first schematic, works fine.
When I tried to assign footprints to my symbols I got a lot of error messages like that:
Footprintbibliothekspfad „/usr/share/kicad/modules/Resistors_THT.pretty“ existiert nicht.
When I looked into the main directory “modules” I found that this exists:
/usr/share/kicad/modules/Resistor_THT.pretty
So I made a softlink from the desired name to the existing directory and it worked.
This happens to a lot of another directories, so I could link them all although it`s a lot of work.
My question is: WHY?
Can anyone help me to fix it quicker.

1 Like

Many thanks,
I think this will help,
btw: I installed a fresh version from .deb package, no update from 4
and I have no idea why my libs are confused that way.

Here’s the complete Version Info:
Application: kicad
Version: 5.0.2+dfsg1-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.64.0 OpenSSL/1.1.1d zlib/1.2.11 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh2/1.8.0 nghttp2/1.36.0 librtmp/2.3
Platform: Linux 4.19.0-17-amd64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.67.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.62.0
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

That library path is in your personal configuration, in the file fp-lib-table. It has been created based on data from v4. You have probably installed v4 at some time in the past, removed it and forgotten it and later installed v5 which used your existing configuration. Maybe you have even copied your home directory from an old OS installation.

Note the version installed.
Really need something newer.
5.1.10 is current.

Indeed. KiCad V5.0.2 was released in 2018, over two and a half years ago. The current V5.1.10 has nine rounds of bug fixes.

So where did you get your .deb package and how did you install it? Debian is a bit notorious for old packages, and you should probably use one of the “backports”.

I started with Debian quite some years ago, but my Linux knowledge is not good enough to maintain it properly. There are too many tasks which have to be done manually. Then I did a bit of distro hopping, and finally settled on Mint with Xfce. With Mint you pretty much click on the update button and fill in your password every now and then and that’s it. (Unless you have “special needs”).

sorry I am late,
I have an additional entry in my sources.list:
deb http://ftp.debian.org/debian buster-backports main
deb-src http://ftp.debian.org/debian buster-backports main