Footprint libraries are on folder but doesn't appear in footprint editor

Hi guys,
im new here :slight_smile:

i have some question actually.

  • So i do a project atm. i dont know why when i tried to assign the footprint and when i open the footprint editor, it’s empty eventho the footprint libraries are there with the files.


    any solution maybe for this? first time it happened, i thought i deleted smth and i made a new project file. The footprint are there but then after a while its gone again :frowning:

  • second question is: what and where i can find +3V3D in kicad?

Thank you

UPDATE:

  • i didnt finde the proper way to solve this although i uninstalled the KICAD before. But there is a way which is that i just made a new black project.
    Before i open and load my footprint for my real project, i open my new blank project and load the footprint. After it’s loaded, i open my real project and load the footprint and the footprint will appear.

So this problem is kinda solved but not really haha. thank you for the helps :slight_smile:

We need to know your version info, OS and if you ever had Kicad installed previously. On my machine I can’t read any of the type face in your screen shot so I’m not going to guess at what I’m seeing or not seeing. :wink:

1 Like

Your screenshot is scaled down and not readable.

Is this your first KiCad project, or have you used it before?
KiCad does not search for libraries, it only uses the libraries listed in the library table, and the first time you run KiCad, it asks you if you want that table to be created for the default libraries. If you decline that, you probably have to create that data yourself. (If you delete the user configuration data (a directory with some files) KiCad thinks it’s started for the first time again and can re-create that data.


There is no “*3V3D” symbol in the current libraries for KiCad V5 (maybe there was for KiCad V4).

In Eeschema you can add new schematic symbols with: Eeschema / Place / Symbol (and then left click anywhere on the drawing area), or just press “a” for “Add”.
That brings up the dialog shown below, and in the encircled box you can enter a search string for schematic symbols. It has a regular expression like syntax and can search for multiple sub strings by adding a space between them. For the string “3V3” it only found a “+3V3” and a “-3V3”.

this is my second project using KiCAD but the first one wasnt that complicated. Now i use it again for my bachelor thesis.

Ah sorry for the unclear picture, was trying to post more picts but didnt work. I will post it again here.
i remember i didnt get that question “if you want that table to be created for the default libraries.” But i made my own library and put it as global, so i can access that globally with other libraries (am i right)?
and i didnt delete anything acutally

thanks for the second problem explaanation btw :slight_smile:

the component is just example and shows that there is the data on the folder but it didnt appear in the footprint editor

I’m not too clear at the moment, so my writing may be a bit confusing at the moment, so be warned.

I’m running linux, and I just moved ~/.local/kicad to some place where KiCad can’t find it and then started KiCad, with the result:
image

And “Calibration_Scale” is one of my default libraries:

It is not clear to me how you get to the file browser window in which you put the “Empty / Not detected?” text. It looks like it’s just looking for a path over there and not for files.

I do see a “-” minus sing in front of your “Calibration_Scale” library in the footprint editor, and I assume that means you can not fold it out to look at files in that library (folder).

I wonder why you had to add the “Calibration_Scale” library manually to the library table. Why was it not added by default? Where does it come from? Is there a possibility you took it from an older KiCad version?
If you go to the project manager, and then **Preferences / Manage Footprint Libraries", there is a column with “Plugin_Type”. If you got that library from an older KiCad version, you may have to set that to “Legacy”.

1 Like

That’s why I asked for version information, OS AND if you had it installed previously. If you had something previous to V5 then your old config file might be messing with things. I think there’s a FAQ entry for that.

1 Like

Regarding your screenshot with this hand written “empty” in it:
KiCad libraries are .pretty folders. The files in them are the footprints. Of course you will not see a content if you navigate into it when using the add library tool! (after all it should show you potential libraries not footprints)

And as a general tip: use proper software to make screenshots. Not paint or some other tool with handwritten hard to read annotations. (After all you are in your bachelors. There is a certain standard expected of somebody in higher education.)


More details about library management


Keep in mind that project local definitions can overwrite the global library table. So if you have the same library nickname in the project library table then this could explain why you do not see anything in the footprint editor.

1 Like

I found the later screenshots perfectly alright.
I prefer the sloppy handwritten text over some nice font, because it makes it abundantly clear that it’s a hand written annotation instead of some text that happens to be on the screenshot.

I also see the “minus” icon before some other libraries:

  • Button_Switch_SMD
  • Button_Switch_THT
  • Capacitor_SMD

Are those libraries also empty?
They should also be normal default libraries.
"Button_Switch_THT for example has about 90 footprints in it on my system:

As the Calibration_Scale library should be one of the default libraries, the quickest fix may be a complete un-install (Inclusive configuration files) and re-install of KiCad.

1 Like

The first thing us ‘old people’ do is go command line and double check. :smiley:

1 Like

ah sorry missed this, mine is 5.1.10
today i found out this:

  • if i first open my real project, the footprint in the library is disappear
  • but if i open a “new project” and open the footprint library from there (which i can access the footprint), and back to my real project, i can see the footprint in the library. it’s kinda weird but works…

thanks for the help but i think its different from linux. i do it in windows.

i will try to reinstall the kicad :slight_smile: if i have more problem, i will ask here. thank you for the help