Footprint from UltraLibrarian has a "disappearing" NP hole

I downloaded from UltraLibrarian the footprint for Molex 2078430006 connector, it has no 3D, but I got that from Molex, and that’s fine.
However this part has a positioning peg that needs a NPT hole, which is present in the footprint, but it “disappears” when I deselect the component in Pcbnew, and it’s invisible in footprint editor …

Now, looking at the .kicad_mod file I find the pads as
(pad 1 thru_hole rect (at 0 0) (size 1.408 1.408) (drill .889) (layers *.Cu *.Mask))
(pad 2 thru_hole circle (at -2.5 0) (size 1.408 1.408) (drill .889) (layers *.Cu *.Mask))
(pad 3 thru_hole circle (at -5 0) (size 1.408 1.408) (drill .889) (layers *.Cu *.Mask))
(pad 4 thru_hole circle (at -7.5 0) (size 1.408 1.408) (drill .889) (layers *.Cu *.Mask))
(pad 5 thru_hole circle (at -10 0) (size 1.408 1.408) (drill .889) (layers *.Cu *.Mask))
(pad 6 thru_hole circle (at -12.5 0) (size 1.408 1.408) (drill .889) (layers *.Cu *.Mask))
(pad 7 np_thru_hole circle (at 1.6 -1.6) (size 1.2 1.2) (drill 1.1938) (layers))
Then pad 7 is assigned to no listed layer? Is this the culprit?

This seems likely, as the “(layers)” section is empty for the last line.
But apparently the hole is visible in KiCad, so load the footprint in the Footprint editor, select the hole, edit it and set it’s layer to Edge.Cuts (Or do that directly with a text editor in the file itself).

If it does not work, then make a simple footprint with such a hole, save it, and view it in a text editor, to look at the syntax for such a hole.

Lokked like I wasn’t able to see it in footprint editor, then I tried assigning it to the same layers of other holes, as “*.Cu *.Mask”.
That worked, however if I open it now I have no Edge.Cuts selection option, see

I made a mistake, sorry for that.
I was guessing at the layers on which a NPTH should be.
So it’s time for plan B, which I also already mentioned.

So what I did:

  1. Click on a random footprint on a PCB.
  2. [Ctrl + e] to load it in the Footprint editor.
  3. Footprint Editor / Place / Pad and place it somewhere.
  4. Edit the newly added pad and change it to: image
  5. Footprint editor / File / Export Footprint
  6. Open the exported file in a text editor.

(pad “” np_thru_hole circle (at 3 -3) (size 1.524 1.524) (drill 0.762) (layers *.Cu *.Mask))
(pad 1 thru_hole rect (at 0 0) (size 3 3) (drill 1.52) (layers *.Cu *.Mask))
(pad 2 thru_hole circle (at 5.08 0) (size 3 3) (drill 1.52) (layers *.Cu *.Mask))

It still has the same layers: “(layers *.Cu *.Mask)”, but the pad number, (which first was 3) has now disappeared. And this makes sense. There is no use for a pad number for NPTH, and a drill does not care much which layers are specified, it’s just drilled through the PCB.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.