Footprint editor takes TOO MUCH time to open

When I tryed to open Footprint Editor, it takes HOURS to load. I have to cancel it.
This was happened in the 5.1.9 version installed via apt in Debian.

Now I tried 7.0.1 with flatpak hopping this get solved, but still happen so is something of my computer. I’ve tryed to uninstal and reinstall many times.

When opened in terminal it prints a lot of this.

Anyone could give me a hint whats happening?

UPDATE: Found the problem
It happen in other caseses and was a problem of python, I don’t know why exactly happened but the cause was a file in my home called
Even if the file was empty it was executed and take a lot of , the mesagge showed was caused by that file, and the time too, it generates millions of tokens and compare to find repetitions.

The solution was to rename that file “/home/my_user/” to another name and problem solved.

That’s an unusual output that I’ve never seen before. It looks like it is running in some sort of debugger or profiler. Since this happens with two very different versions, it sounds like you might have a unique setup with your operating system or hard disks.

Do you know if is something related to the message Failed to load module “xapp-gtk3-module” ?

Probably not, but you could install “xapp” to check.

It looks like some application is running a search (BUSCAR) in the background. Maybe antivirus?

I did a general search for “xapp-gtk3-module” and found the link below, which suggest that installing xapp may indeed resolve your issue.

I’ve tryed to install xapp and is installed, I don’t know why the error.

I don’t know if other application is searching something somewere. But its the only time I saw this.
It start When I open the PCB editor or the Footprint Editor, and after 2 hours, when it reach *** 1999 *** the editor open and works correctly.

I tryed all solutions in the post and the message still showing.

After several attempts, I left it to see how long it took.
I finish after 2 hours. When I finished I was able to use the footprint editor and the PCB editor correctly.

As long as I didn’t close the program, I was able to use it correctly. Once I closed everything and reopened it, again I had to leave it for 2 hours until I could use it.

I don’t know if it has something to do with it, but the fp-info-cache file weighs more than 3MB.

Perhaps more of an FYI but, may help…

Kicad comes loaded with enough Footprints, STEP and WRL files to choke a horse. Many users don’t need most of them for most projects so, simply Un-select those not needed and they won’t load - thus, saving time. User can always re-enable them…

I disabled all symbols and footprints library and still happen, when it finished loading, there was no library to edit.

I could try remove (move to another location) all unused and see what happen. Didn’t work, still slow load.

Most likely this won’t apply but, worth mentioning it…

I’m using v6 (won’t upgrade for at least six months until 60% of Bug’s are dead).

In earlier versions, one of the Paths pointed to Git-Hub and if/when not able to access that site, Kicad footprint loading took all day and never completed. I deleted that Path and all worked well…

This is not your direct problem, but the KiCad footprint library system of one file per footprint, suffers badly on spinning disk hard drives that have directory fragmentation and therefore slow file seek

m2 ssd is quite accessible to all users and there is no problem putting a working system on it instead of the usual hdd

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.